1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
Dismiss Notice
Like RaceDepartment on Facebook.

DUAL CORE USERS - Solution to puddles, dry line and race line AFTER PATCH!

Discussion in 'F1 2010 - The Game' started by fer314, Nov 6, 2010.

  1. (First of all sorry for my english, I speak spanish, I used Google translator for this)

    This solution is a mix of the CM hotfix and a CM forum user idea, neither of the 2 separate solutions worked for me, the first one corrected the bug in the puddles but the FPS dropped to 50%, the second did the opposite, increased the FPS but did not address the puddles and the other bugs, but testing and testing and mixing the fixes I have everything working very well now...

    Tested by me on a Dual Core system, but maybe can work also in a quad core system.

    My specs:

    - AMD Athlon 64 X2 Dual Core 5000+
    - XFX GeForce 9800 GT
    - Super Talent DDR2 800 - 4 X 1024 (4Gb)

    IMPORTANT! We must implement the two solutions together to make this work!
    Do the following:

    1- First BACKUP THE FILES! Then add this line <track_info_system type="gpu" /> in the penultimate line (before '</hardware_settings_config>') of your hardware_settings_config.xml (in documents and settings/formulaone folder)... your last two lines should read:

    <track_info_system type="gpu" />
    </hardware_settings_config>

    Save the archive.

    2- First BACKUP THE FILE! Then open workerMap2Core.xml (in C:\Program Files\Codemasters\F1 2010\system folder), go to the end of the file and set the trackinfo like this

    <workerSet name="trackinfo" jobpoolsize="1024">
    <worker name="core_1_below_normal" />
    <worker name="core_0_normal" />
    </workerSet>

    (Note that you're changing <worker name="core_1_normal" /> by <worker name="core_0_normal" />)

    Save the file.

    PLAY THE GAME!

    If you want to see the drops on the camera as they did originally before the patch, do the following:

    Copy the files postprocess.pssg in their original pre patch versions and replace the new versions that the patch installed in C:\Program Files\Codemasters\F1 2010\dx9\shaderpack and the one in C:\Program Files\Codemasters\F1 2010\dx11\shaderpack folders.

    Remember to BACKUP THE FILES before replace!

    If you don't have the original postprocess.pssg files, here is the link to download it:

    http://www.megaupload.com/?d=CH9G5CKL

    Try this and comment if this work for you!

    Happy race!
     
  2. tried this with PC in sign, everything work but i have a huge FPS drop (from 51 to 35 FPS at the start), with gpu usage stuck below 75%, thx for your effort anyway ;)

    P.S. tried also to revert to the original postprocess.pssg but FPS drop remains
     
  3. Thanks, will give this a shot.
     
  4. Hi Dalhil, did you try changing the two options together everything as explained here? Not work well separately but together work great at least for me... no FPS drop
     
  5. sure, that was the first i did ;)
     
  6. Please place a link to the original files to another file sharing, because I can not download.THX.
     
  7. Thanks for original files. Water drops a bit less pixelated now.

    Modifying workerMap2Core.xml did not improved fps. But it is true that 2 statements for core_1 seems to be a bug.

    Before modification of first file, in the Silverstone graphic test, I had 48 average and 38 min, now I have 35 average 29 min.

    It is fluid and playable even under heavy rain, so I will keep that because puddles are lot better like that, huge difference...

    I play at 1600x1200 all maxed out , AA 8XQ

    W7 64 bits, 4Go ram, Core2duo E7200@3.8GHz, GTX275 stock speed.
     
  8. All works a treat for me, with good fps as well.

    Rain spots are better but still a little pixelated.