1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Driving cameras skewed at angle

Discussion in 'Automobilista' started by William Wester, Apr 27, 2017.

  1. William Wester

    William Wester
    Premium

    Messages:
    1,132
    Ratings:
    +381
    Note, I've posted this on the official forums but no help there...

    I've run into this in GSC some time back (over a year ago) but don't remember how I fixed it.

    I've had Automobilista running fine since release but switched to triple screens last week. Everything still fine with triples until I switched back to my single monitor for some quick testing. Now the driving camera views are all skewed to the left - angled to the left. Anyone know how to correct?
    Cockpit cam.png Hood cam.png


    Thanks
     
  2. Stephen O'Sullivan

    Stephen O'Sullivan
    Premium

    Messages:
    87
    Ratings:
    +83
    A wild guess: Do you have the "windowed" option on in the config menu? Switching it off might help.
     
  3. William Wester

    William Wester
    Premium

    Messages:
    1,132
    Ratings:
    +381
    Thanks for the suggestion, but no, full or windowed option doesn't make a difference.
    What's interesting is that the general AND beta versions both have this problem. I assumed the beta was going to be fine as I didn't think I ran the beta since switching to my triple screen setup. I assumed the settings would have been preserved but it seems that the setting that affects this is common between both AMS versions. Until I can find a fix, I have to use swingman view - will old REAL quick.
    I guess I'll have to stick with R3E and rF2 otherwise, don't feel like a complete new install and reload of every mod.
     
  4. Stephen O'Sullivan

    Stephen O'Sullivan
    Premium

    Messages:
    87
    Ratings:
    +83
    Hmm. Another shot in the dark: how about deleting the DynHud folder and then verifying the Steam files?
     
  5. Simon Hodge

    Simon Hodge
    Premium

    Messages:
    99
    Ratings:
    +68
    i had that!! mine was look left was mapped aswell as brake... so check what look left is mapped to
     
    • Agree Agree x 1
  6. William Wester

    William Wester
    Premium

    Messages:
    1,132
    Ratings:
    +381
    I found the problem, for testing I wasn't using my rig w/triple screen setup and wheel/pedals/shifter. I just switched to my single screen (4th monitor on same computer) and used an XBOX gamepad. The gamepad mapped as JOY2 but the TH8a shifter was still connected and mapped as JOY1. Even though I didn't see anything mapped to JOY1 the shifter was causing the driving camera issue. Very strange, none of my other sims was affected like this, only AMS.
    Thanks for the suggestions.
     
  7. Stephen O'Sullivan

    Stephen O'Sullivan
    Premium

    Messages:
    87
    Ratings:
    +83
    I'm glad you solved your frustrating problem.

    One day, someone will make a real racing simulator called: Get It Working 2018. Thump your desk in frustration as you battle against error messages. Scream at the monitor when the aspect ratio stretches everything. Thrill to that moment when the bloody thing works properly. Coming to a PC near you! :D
     
    • Haha Haha x 1