1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Does teh new physic affect steering?

Discussion in 'WRC 4 The Game' started by Sk3ptik0n, Dec 21, 2012.

  1. Sk3ptik0n

    Sk3ptik0n
    Premium Member

    I downloaded and installed the new Physics from EC Sim. Unfortunately the frigging retarded download service they use made me download the physics file twice and when I went to download the plugin, it told me I have to wait 6 hours. Imbeciles.
    Anyway, I installed the phisics and something very strange happened. I have a G25 and I had created a profile for WRC3 that worked just fine. My G25 and the on screen wheel were at least close in range. The onscreen wheel is a bit behind but the driving was fine.
    I think I had set it at around 400 degrees or close to that.
    Today I go driving and I have to turn my wheel 3 times to make a half turn in the game.
    I tried all sort of different ranges but finally the only one drivable was to set my G25 at 117 degrees. Still, I had to turn my wheel 180 degrees to get a 1/4 turn on screen, but better than the alternative. It was like driving a school bus.
    This is the first time I drive the new physics. Is it because I am missing the plugin? Should I wait until I can download it?
    it sure it's frustrating to have to drive like this. Other than that, the new physics feel pretty good.

    Thank you.
     
  2. Sk3ptik0n

    Sk3ptik0n
    Premium Member

    OK, I solved the mystery on my own. I had started ERC3 as an administrator to see if I would gain anything by it. Sure enough, I did because by starting as an admin I was able to navigate the tabs in the Car Setup screens by pressing F5 and F6. So I kept starting like that, except that the steering was terrible. At first I didn't correlate the two things but I just tried to start normally and the steering is back to normal. So I have a choice of:

    a) Don't steer the car but set it up
    b) Don't setup the car but be able to drive it.

    Easy choice. Hopefully they will fix this mess.
     
  3. Rupe Wilson

    Rupe Wilson
    Keep Yoga real Premium Member

    I sent you a pm with a download of the plugin just after you posted...
    i dont seem to have the issue you are stating...
    Dont know what is going on maybe a clean install will sort out the problem:)
     
  4. I have the same problem. I cant turn with this mod. First problem is that everytime i run wrc3 i have to change screen setings etc in th advanced plugin window. They dont save. Second, i cant adjust the wheel settings, in the game turning is very bad. Can anyone help me with these 2 problems?
    Thanks
     
  5. Rupe Wilson

    Rupe Wilson
    Keep Yoga real Premium Member

    Try in this section for answers ( CLICK )
    Ive only changed the setting in game, and had very little problems myself,
    i did mine on a clean install no other mods or effects at all..
     
  6. Sorry if i'm wrong but in case you have the same experience with me.. AFAIK, you have to assign the wheel into the Advanced Plugin Interface that popup after you click the WRC3 icon. Assign Steer Left and Steer Right (do it with turning your wheel) and the Accelerate and Brake needs to be assigned as well. The Paddle Shifter doesn't have to be assigned though. It will cause your car shift twice in the game if you choose to assign them.

    My wheel is DFGT and before i can't turn the car in the game. after doing some reassignment, now it's perfect for me :)
     
  7. Sk3ptik0n

    Sk3ptik0n
    Premium Member

    Thanks for the replays guys. I was away for Christmas so I couldn't check the forum or test WRC3.

    I just wanted to let you know that I have been using the plugin. It resolves some issues, but not the ones I am really struggling with. Namely, the steering is fine if I start the game normally, but once I am in game, I simply cannot navigate the Tabs in the garage.
    However, if I start the game as administrator, then I can do that using F5 and F6, but then the steering is all wrong, regardless of the plugin use.

    Incidentally, I have at least another menu issues, which is the advanced wheel settings. They worked fine the very first time I setup the game, but after that, each time I select the menu (F2) I land in the page and I can only change one of the sliders. In other words, my Up/Down arrows don;t work at all. Strangely, each time I exit and select the same screen, I seem to land on a random items so if I spend a long time entering and exiting the adv. wheel setup eventually I am able to use it. Or I can start as an admin, set the wheel, save, come back and start normally, which is what I did.

    The garage screen is different. It's already a pain to set up your car before a stage, but if you can't navigate the tabs it's useless. I would need to create my setups without actually trying them, exit, restart and then test them. Too much of a pain.

    I also wrote to Milestone, but I received no answer at all. I wrote my submission half in English and half in Italian, hoping they would at least notice the request for support more. Nope. Maybe I'll try Klingon and tell them I'll explode their star. See if that work and they release a patch to fiox the broken menus.

    PS: I also tried to use an Xbox controller, just in case. No dice.
     
  8. I have those menu issues too

    for the tabs in the garage screen I can use F5 / F6 (might be F4 / F5) to switch tabs

    As for the up / down arrows it is hit and miss when they work but if the keyboard does not work the pad on my Porsche GT3 RS wheel seems to work
     
  9. Sk3ptik0n

    Sk3ptik0n
    Premium Member

    Not for me unfortunately. I have a G25 and I have tried every button. I even downloaded and bought Xpadder to see if somehow I was able to trick it. No dice.

    I wrote to the developers and they responded that they are going to release a patch that should solve most problems. Obviously, they are not rushing to release it.

    Also, if I were them I would have asked a few more questions and maybe even asked me to try out a beta patch since most other customers are able to use the F5/F6 while I am not.

    Anyway, here is to hoping they'll ficx it someday. I am not driving it much anymore because each time is a chore to get it going with all the special controller things I have to do to play it.