• “Just being a mediocre driver has never been my ambition. That's not my style” ― Michael Schumacher
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. Have a chance to win a copy of F1 2017 The Game (PC) by following RaceDepartment on Twitter, Facebook, Instagram, Twitch, Steam and / or YouTube.

DFGT Issues

Discussion in 'Sim Racing Hardware' started by domhnall, Aug 1, 2017.

  1. domhnall

    domhnall

    Messages:
    9
    Ratings:
    +1
    Hi all. I'm having some issues with my DFGT wheel. Maybe someone can help.

    It started with a windows 10 update about 2 weeks ago. After the update the wheel was recognised as a different wheel in logitech (not sure exactly which model tbh). The wheel was still working fine, but some of the buttons were not being recognised in game, which was a pain. I had a similar problem about a year ago, which resolved itself after a few days. Was hoping for a similar result this time.

    Yesterday the problem was persisting, so I tried reinstalling the logitech gaming software to see if I could get the wheel to be recognised properly. Initially it looked like this had worked, the wheel and all buttons were recognised properly. However I have run into serious problems when trying to actually use the wheel in game. I have tried to use it in both RF2 and AMS. I both games when I press the race button, to leave the garage, one of 3 things happens;

    1. None of the inputs from the wheel are translated to the game (despite being recognised in the main menu controls section beforehand). It is like the wheel is simply not detected at all. After I escape and return to the main menu, the wheel is still not detected at all. I have to plug the wheel in and out again to get it detected, but again if try to leave the garage the detection will be lost.

    2. When I try to turn the wheel, the wheel automatically does it's 'full lock check'. Not sure if this is the correct terminology, it's the test it normally does when you plug the wheel in, and it rotates left and right to it's full lock, before returning to the center. It does this every time I try turning the wheel.

    3. The wheel works, but is very 'stiff' and it is very difficult to turn the wheel. This is even with the spring stiffness set to 0% in the logitech gaming software.

    Any ideas on this?? Note sure if it's relevant, but the wheel is quite old, I bought it back in 2009. Was working perfectly before the windows update. Any help would be appreciated.
     
  2. Martin Fiala

    Martin Fiala
    Oh no! It's him again! Premium

    Messages:
    1,982
    Ratings:
    +2,045
    That Win 10 thing is a known issue - with some updates, Windows also updates the wheel's drivers, and because Logitech screwed up, the newer drivers don't support the old wheels properly. The DFGT gets detected as the old blue Driving Force Pro. It was possible to avoid this problem by disabling hardware drivers updates in Windows, but ever since the Creators update, it doesn't seem to work - Windows just ignore the setting and update the drivers anyway.

    I always fixed it by simply uninstalling the Profiler software (which also uninstalls the drivers), disconnecting the wheel and then going through the setup again using the correct software package. Didn't even lose my Profiler settings like this.

    As for the other problems, I never experienced anything like it. But make sure you're really using the correct drivers for your wheel - I believe Logitech has meanwhile fixed the drivers (they had the wrong drivers to download even on their site, also they didn't bother to change the version number, so it was pretty confusing) and you can download the correct ones here:
    http://support.logitech.com/en_us/product/driving-force-gt/downloads

    However, to be honest, it sounds like your wheel might have some bigger issues...
     
  3. domhnall

    domhnall

    Messages:
    9
    Ratings:
    +1
    Many thanks for the reply.

    Well everything seems to be working again. I tried reinstalling the drivers as suggested above. First attempt didn't work. For the second attempt I plugged the wheel into a different USB port. Now all is well and the wheel is working as before. Very relieved :) Thanks again for the help.
     
    • Like Like x 1