• Blurring the line between real and virtual motorsports
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Dark objects in BTB

Discussion in 'Bob's Track Builder' started by sadistiko, Nov 24, 2010.

  1. I saw some day something about this problem. My houses in SketchUp looks much brighter than in BTB. I saw what we must do to fix this but I can't find it now when I need it :-(
    Can anybody point me in right directions please? :redface:
  2. Did you calculate the normals in xpacker before you packed it? Don't set it to up normals because it wont have any dynamics.

    Also, how does it look in game? It will render different in all 3 environments (sketchup, btb and in game)
  3. When I come home I'll make some screenshots and post here. Also, first I'll try to play with normals. Not sure what settings to use. If I remember good there is 3 options.
  4. @ mianiak - I would like to ask - what's better - to set normals up in objects separately or to set them globally for the material of them (I'm speaking of trees when they use one material)?

    @ sadistiko - I think Sketchup does something with maping that they look this way (e.g. too dark shadowed walls). Normals up seem to be the only compromise for this case.
  5. I don't think you can set the normals up for just the material.

    re: The dark shadowed walls, If you have a 90 deg corner on a low polly object like a building, you need to separate the faces into separate elements, if you don't, the 2 faces will join together with each other and the smoothing will make it look funky. By separating the faces you end up with a sharp corner.
  6. I see, thanks! There is a check box in XPacker "Render Normals Up" - I'm using it all the time with my trees and other objects and it works... for RBR ;)
    What about the distance of separation you could suggest - I guess the smallest? Does it produce more vertex then? And I wonder the egdes can blink in this case?
    Sorry for too many questions :)
  7. That normals setting in xpacker is for the objects, the min separation is how far apart the same object is placed when you put them down using the auto thingy.
  8. I didn't make any screenshots because normals set to up solve this problem. Buldings now look almost same in skechup, BTB and rfactor. I used default option for normals, so it didn't work well before.
    Thanks martinez and mainiak