1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

CSW not propperly recognized

Discussion in 'Project CARS' started by Dietmar, Jun 9, 2014.

  1. Dietmar

    Premium Member

    Hi all,
    just wanted to give pCars another try, but having the issue, it does not recognize my CSW´propperly. Some buttons are recognized, some are not, unfortunately e.g. the turn-left function is not recognized (tried to assign it,but does not work).

    Any idea?
  2. mod-edit: or for once just provide support here

    author-edit: I actually do answer things here when I can. It so happens that on the WMD forum, there is a 177 pages long Fanatec support thread with many Fanatec users and official testers. There you'll find discussion about all kinds of Fanatec/pCARS issues and solutions to them. As it happens I tried to provide the best possible help for Dietmar - he might not be aware of that support thread. I can't see how denying Dietmar that URL is making anything better.

    Edit for reference and context: My original posting read (XXX replaces unwanted URL):
    Mod-edit: you are still not helping with the problem. :) If the OP wanted to ask his question at XXX he would have started a thread there. He choose to do it here.

    Author-edit: Hehe, I like a conversation in a single posting, preserving screen space and database entries :D I tried my best to help, but I'm not allowed to; as mentioned, the OP may not know about the extensive Fantec support for pCARS going on at WMD. BTW, XXX is not a forum, but an existing and very useful thread exactly for the purpose of solving problems like the OP has (now he's run into more), and it's not certain that the OP specifically doesn't want help where it can most realistically be had. I still can't see how the mods are helping by prohibiting a reference to the most exhaustive pCARS/Fanatec solving resource on the planet. If the mods would reconsider, I could paste that URL right back in for everybody's benefit.
    Last edited: Jun 10, 2014
  3. Dietmar

    Premium Member

    Recognized something else, not sure whether it is the same issue or a different one;

    I recognized there are some presets for certain controllers, unfortunately I cannot search though it, because once I go with my mouse over the respective arrows, it flashes through the controller, I just cannot select anything.....
  4. Dietmar

    Premium Member

    I actually do know the resource you suggested, Dr Justice, but 2 problems with that:
    1) I do not have enough privileges to post there.
    2) That thread is 180 pages long and a plain search did not bring the results I needed.

    So that's why I came here, as I can post here and usually people are very knowledgeable.

    I would suggest, back to main topic, my csw is still not working and I do have the issue with the mouse now on the main menu.......
  5. museumsteve

    Premium Member

    May be an obvious suggestion but have you tried deleting your profile in mydocuments/CARS and starting form scratch.
  6. All tiers should be able to reply to threads (just not start them). Anyway, your issue has been brought to attention over 'there'.
  7. Dietmar

    Premium Member

    I actually did try that one, now I have the 'mouse problem' on the main menu, means I cannot enter the options. What is happening is, is that the focus scwitches a couple of times between Solo Career and whatever there is on the main screen, without the chance to click anywhere.

    I managed to get once into the controller settings, managed to select the CSW preset, but the settings where incorrect. Again, it did not recognize me turning my wheel left (other buttons worked), when I tried to edit the assignment.
  8. I recently had some issues getting Pcars to work with my CSW. I was unable to assign the proper functions to the buttons I wanted - including pedals and shifters. As it turns out, I had just added the CSS-SQ shifter but, had not yet calibrated it so Pcars was seeing multiple inputs at once. Once I performed the calibration as per the Fanatec calibration video, the problem was solved.

    Perhaps you have something that is not properly calibrated.

    Also, it's highly recommended that you delete the entire "Cars" folder in your documents folder after each update to avoid any conflicts. It does mean that you have to reset your preferences after updates but, also avoids possible issues.
  9. Dietmar

    Premium Member

    The calibration is only required in case of a shifter, isnt it? I 'only' have CSPv1 (connected via USB) and the CSW.

    I deleted yesterday the game itself (from Steam) and my folder in my documents folder.
  10. It might be worth your while to re-calibrate the wheel anyway just to eliminate any potential issues.

    Do you have the pedals plugged into the wheel base or directly via USB? Mine are direct to PC - haven't tried running them to the base.
  11. Dietmar

    Premium Member

    The only calibration I am aware off is the centering, just did that, but does not change anything (though there is actually a slight problem with that as it does not go to center position when switching on, but even by the fanatec tool it is off center, the center is where it is supposed to be, if you understand what I mean :) ), Pedals on USB.
  12. Yeah, my base doesn't stop center either but, works fine in-game. Some other things I can suggest is to check the settings in the Fanatec software to be sure all buttons and pedals are working correctly and there is nothing that might indicate any duplicate or multiple input signals.

    Are you running the latest firmware and driver for the Fanatec? Have you tried using different USB ports on your PC? Beyond that, I'm out of ideas.
  13. Dietmar

    Premium Member

    Yes, I am on latest Firmware and Driver and the issues only arise in combination with pCars, AC, rf2, R3E no issues.

    Got a little bit further though. The mouse issue is connected to the wheel, it only happens when the wheel is not centered. In the moment I center the wheel,all is good with the mouse.

    The turn not being recognized remains.
  14. Do you see a message saying "Multiple inputs recognized" or something like that?
  15. Dietmar

    Premium Member

    No did not. But....

    I cleaned again everything, including a version from pre-Steam-Times and it is working now, I still cannot manually assign turn-left, but when I choose the preset for csw it is working.
    Last edited: Jun 11, 2014
  16. I guess I never have tried to manually set the steer inputs - only the pedals and paddles. Glad you have it working.