1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
Dismiss Notice
Like RaceDepartment on Facebook.

CSR Elite Pedals - Throttle input needs to be inverted for R3E, but can't see how

Discussion in 'RaceRoom Racing Experience' started by Metalogic, Jul 16, 2016.

  1. Metalogic

    Metalogic
    Premium Member

    Hi - I've just got a Thrustmaster T300 wheelbase, TM Leather 28 GT rim, and a set of Fanatec CSR Elite pedals. The pedals are connected directly to my PC via USB. I have the latest Thrustmaster drivers and firmware installed and also the latest (beta) Fanatec drivers. All inputs from both the both the wheel and the pedals register in their respective control panels.

    I have no problem assigning the throttle, brake and clutch controls to the pedals, and the steering inputs and other controls to the T300/28 GT. In R3E, though, for some reason the throttle input from my CSR Elite Pedals is inverted - so when not depressed acceleration is at 100% and when fully depressed is at 0%, but I can't see anyway in R3E to invert the inputs, unlike in AC or AMS, where they work fine. Any suggestions?
     
  2. PaulH

    PaulH
    Premium Member

    That's very odd, I have these pedals and they work no problems in R3E, perhaps rebind them with your foot fully down on the pedal before pressing the appropriate key, not sure if that works but it must be something silly :O_o:
     
  3. Metalogic

    Metalogic
    Premium Member

    Okay, I'll give that a go. I also had problems getting R3E to recognise any inputs from the pedals initially, but seem to have sorted that out somehow, it's just the inversion issue that's the problem now. How come there's no manual inversion option in R3E unlike in other sims? Is it just meant to handle this automatically?
     
  4. PaulH

    PaulH
    Premium Member

    What about if I give you my control profile, its for a TX but you can change the keys for that but just to see if the pedals work? Maybe that will work? :cautious:
     
  5. Metalogic

    Metalogic
    Premium Member

    Aha! I've got it working somehow, not sure what I did exactly, but it's now registering the inputs from all my pedals the correct way round now, hurrah! Just took the Canhard R51 for a practice drive around the Nurburgring and all seems to work, though I think the wheel settings need quite a bit of tweaking! Will have a look at some other user's settings for the T300. BTW what steering lock dpo you need to use with most cars (18?) and what degree of rotation of the wheel - 900 or much less? First time I've ever used a wheel in R3E!
     
  6. psynusoid

    psynusoid
    Premium Member

    Steering lock for me wasnt far off. I settled with 13 (default) or 14.
    I have followed Lars leaderboard ghost around with totally default settings.
    I have had to dial down the cars ffb multiplier (2.290) as otherwise I just get clipped ffb.
     
  7. Metalogic

    Metalogic
    Premium Member

    Okay, thanks. Is this with 900 degrees rotation on the wheel? BTW how do you open the clipping meter?
     
  8. psynusoid

    psynusoid
    Premium Member

    I have my clipping meter bound to F - I think its under secondary controls
    900 degrees (default) in the thrustmaster panel and 540 on the car.
    I think r3e changes the settings for max rotation anyway.
     
  9. Metalogic

    Metalogic
    Premium Member

    Okay, is it okay to get occasional clipping? At about 75% FFB intensity it's mostly okay, but occasionally peaks into the red.

    I think you're right about the max rotation, R3E seems to set sensible defaults for each car
     
  10. psynusoid

    psynusoid
    Premium Member

    Mine peaks above the red line but most of the time is below.
    Most of the time the defaults result in a driveable experience.
    Macau is the exception where i dont even think the car can make one of the turns without increasing steering lock.