1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

CSR Elite Pedals Brake Problem

Discussion in 'Sim Racing Hardware' started by Mach, Mar 8, 2015.

  1. Mach

    #47 G.R.Webb Sidecar Racer 1962-1972

    I've had the pedals less than a week and used them for less than an hour....and they are great, but.....big fat butt!!! The brake is sticking electronically....physically fine, the pedal is fully released but the brake registers anything from 5-25%..this is the amount I have to increase the deadzone to fix it...obviously not an ideal fix...The problem lessens if I reduce the sensitivity on the pedal itself...if I disconnect the pedals and reconnect it also fixes the problem (temporarily) it comes back within 5-10 mins!..I have sent 5 tickets to Fanatec, and I'm getting very little back!

    Any one experienced the same thing?? I have a video, but they have asked for it not to go on you tube....but it's going on if they can't respond tomorrow. I can't upload it here either for some reason...Any help appreciated. :thumbsup:
    Last edited: Mar 8, 2015
  2. I'd say try a different USB port and reinstall the drivers again. Try setting the load cell at 10 to begin with and make sure you can get 100% brake pedal travel in the Fanatec control panel. If that didn't fix it, you may have a bad load cell from the factory.
  3. Mach

    #47 G.R.Webb Sidecar Racer 1962-1972

    Cheers Blkout.. Appreciate the response. I can get 100% no problem. In all the ports it works fine.. I have tried the driver a few times and even gone back one version but still the same. I've a feel feeling they are heading back...
  4. Maybe I misunderstood, are you saying that you can register 100% but the brake sticks sometimes at 5-25%? Does this happen in the Fanatec control panel or in a particular game? Very unusual problem, have you looked to see if something is physically binding or getting caught when the pedal is returning to start position?
  5. Mach

    #47 G.R.Webb Sidecar Racer 1962-1972

    That's right mate, exactly that... I will have a look at the pedal more closely but I'm pretty sure that without taking it apart it seems fine. Thanks again man.
  6. Mach

    #47 G.R.Webb Sidecar Racer 1962-1972

    Sorry for the double post....

    Fanatec are sending me a new pcb and load cell.
    Last edited: Mar 9, 2015
  7. Good deal man. Make sure to let us know if that fixed the issue.
  8. Mach

    #47 G.R.Webb Sidecar Racer 1962-1972

    Will do dude.... Thanks fella.
  9. James Cook

    James Cook
    Marcas fan

    Sorry to hear you've had problems, Matt, but at the same time welcome to Fanatec ownership!
    • Like Like x 1
  10. Mach

    #47 G.R.Webb Sidecar Racer 1962-1972

    I've just taken delivery of a new Load cell and Pcb...free from Fanatec.

    Now where's my hammer..?
    • Haha Haha x 1
  11. @Mach

    That was fast, go Fanatec.
  12. Mach

    #47 G.R.Webb Sidecar Racer 1962-1972

    Fixed, just broke em in.. ;)
  13. Good to hear. Hopefully they last longer this time around.