1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

CSP V2 - throttle pedal problem

Discussion in 'Sim Racing Hardware' started by Galin Dimov, Mar 20, 2016.

  1. Galin Dimov

    Galin Dimov

    Hi Guys,

    Has anyone experienced the issue I am having with my pedals? Basically, when I press the throttle, it spikes all over the place and even fully pressed, often it doesn't register the same in the Fanatec software.
    Here is a video that explains the problem far better than I can do it with words:

    Does anyone have an idea how to fix it? I've tried different USB ports; stiffening/softening the pedal; re-installing the software etc with no success.

    I should have said that I had the same issue right after I bought the pedals (3 days into owning them basically) with the brake and the problem was the load cell but the behavior was exactly the same

    Last edited: Mar 20, 2016
  2. David O'Reilly

    David O'Reilly
    A bad quali means I can go forwards in the race.

    Could be a potentiometer issue.
    Try downloading and using DIView to check the performance of the pots.

    It can also be used to tweak the settings/calibration.
  3. Galin Dimov

    Galin Dimov

    Thank you David. I am not sure what to look for in DIView but if I look at the Pedals' X rotation, it shows the exact same behavior - when the pedal is fully pressed, it goes down to 25% basically and still spikes.
  4. David O'Reilly

    David O'Reilly
    A bad quali means I can go forwards in the race.

    Well it seems the pot is failing.
    You can use DIView to tweak its minimum and maximum range.
    IE 25% as max but you probably should order a pot. Fanatec €10 plus freight for a basic 10kb ohm unit or €3 of you do some homework!
  5. Galin Dimov

    Galin Dimov

    I thought setting it at 25% but the problem is it still spikes - it goes to 25; 28; 22; 0; 30 etc. so it's not going to work...it's not 25% constant. Anyway, I have dropped a mail to Fanatec for a solution.
  6. Thomas Cameron

    Thomas Cameron
    Don't give me your patter Premium Member

    The problem will be dirt at the side of the pedal where the Hall sensor is.

    it's not a pot it works with magnetic contact.

    Just take the 3 screws out carefully and clean it all thoroughly then put it all back together, it should feel like new.

    I had the same problem and just cleaned the accelerator and the clutch , never had any more problems

    Hope this helps you

    Last edited: Mar 21, 2016
  7. Jason Palmer

    Jason Palmer
    Premium Member

    Funny enough to just had to clean the magnet behind the sensor just last week before the 12 hour of Sebring race on iRacing as the throttle pedal was spiking.

    It's Something I have had to about three times in the couple of years I have had the pedals, in my case it's generally a build up of dog hair !

    A few things to check and try as well,

    If your pedals ever play up try another USB port as this can sort a few issues out, make sure it's a USB2 port as they prefer that.

    Please becareful when taking the casing for the sensor on the side of the throttle pedal off as there are three very small plastic spacers in between sensor and pedal and they can roll for miles, don't ask me how I know ! And when tightening up those small Allen key bolts only pinch them up just enough that it holds the sensor in place as it's very very easy to over do it and bend the casing crushing it down on to the sensor.

    Also if you turn the pedals up side down you will see a very small Allen key bolt in the section between the pedal outer edges that holds the bar with the magnet on in place and this can sometimes come lose allowing some play in the bar meaning that the sensor does not always pick up the full travel of the pedal.

    These little fixes are a little fiddly but only take a few minutes and only really need to be once in a while and really do help to keep the pedals in as new condition.

    • Like Like x 1
  8. Galin Dimov

    Galin Dimov

    • Like Like x 1
  9. I had the exact same problem with my V2's what I did was replaced the censor and that fixed the problem. My problem was with both the brake and accelerated pedals.
  10. Galin Dimov

    Galin Dimov

    Yes I guess will be the same. Tried cleaning everything but still the same unfortunately. Fanatec replied that it's a faulty sensor and already sent me a new sensor.
    Last edited: Mar 22, 2016
    • Like Like x 1
  11. Keep an eye on that issue relative to time.
    I had the very same with my set of V1 Clubsport pedals.
    I cleaned them, checked security of the three screws holding the sensor and after none of that fixed it, I replaced the sensor.
    That seemed to fix it.
    A few month later, it again started happening.
    Once more, the sensor was replaced.
    A few more months....and you guessed it.....same thing.
    This time I looked a bit further.
    I elected to replace the main circuit board at the pedals....and that fixed it.
    Have not had any problems since.
    No spiking, no loss of max throttle, no USB disconnects etc...