1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

PC Crossfire only working on 1 gpu...

Discussion in 'Assetto Corsa' started by JimmYPT, Nov 16, 2013.

  1. Just edit this post to make the thread smaller...
     
    Last edited: Nov 28, 2013
  2. hey guys

    here is my problem...
    I have crossfire 2 gpu's and evertime i play any game ( in Fullscreen), the second card is almost idle.
    I also have triple screens and the workload is even higher on the main gpu when they are in eyefinity mode... :(
    The bridge is well connected and i already tried changing the gpu's position and the situation also remains the same.

    I was told to disable "enableulps" in regedit which i did, but the only ones available are: "enableulps"(which is at 0) and "enableulps_NA" (which is at 1)

    I have posted this video, but its the same with any other game, even in fullscreen mode.

    video

    I really haven't found a solution and was wondering if anyone has this issue.

    this is my specs:

    CASE: Coolmaster CM Storm STRYKER | MOBO: ASUS SABERTOOTH Z77: INTEL Z68 Chipset |CPU: INTEL CORE i5 3570K (3.4GHZ) | RAM: 8GB GSKILL KIT DDR3 1600MHZ NQ, X.M.P | GPU: Crossfire 2 x 2GB AMD Radeon XFX HD 6970 | HDD: SSD Samsung 2.5" 840 250GB | PSU: Corsair HX 750 | OS:Windows 8 Pro x64 | Monitor: 2 ASUS VW222U, 1 ASUS VW224 (1650 x 1050 * 3 = 5040 x 1050) | Game Controller: Logitech G27... Buttkicker gamer2. + TrackIR5..+ Saitek Cyborg R.A.T 3

    [​IMG]Uploaded with ImageShack.com
    [​IMG]Uploaded with ImageShack.com

    [​IMG]Uploaded with ImageShack.com

    [​IMG]Uploaded with ImageShack.com
     
  3. Bram

    Bram
    Roaring Pipes Maniacs | #27 Staff Premium Member

    Ive merged your two posts into one thread. Somehow ended up double on the forum :)
     
    • Like Like x 1
  4. thank you
    i wanted to do that but i wasn't able to do so :)
    cheers
     
    • Love Love x 1
  5. William Wester

    William Wester
    Premium Member

    I had the same problem with my CrossFire'd HD7850's until I installed the 13.11 beta drivers - was running 13.9.
    Not sure if it is related but for me the drivers did the trick.

    Windows 8.1 in my case.
     
  6. Graham Laing

    Graham Laing
    ...... mostly harmless Staff

    I have 2 crossfired HD 7970's on Catalyst 13.9, and sometimes crossfire worked and sometimes it didn't.

    When I first got AS I ticked the box in CCC to enable crossfire in games which do not have a CF profile. Now I force a profile via CCC specifically for this game. I force the profile 'AFR Friendly'

    However crossfire was still tempremental, and using MSI Afterburner to monitor the cards, I could clearly see that GPU2 was often not used at all. It was like the system was running in 2D desktop mode ...... and that was precisely what was happening.

    There was no difference whether I had the game set for full-screen or not. So I tried the keyboard shortcuts commonly used to get most games into fullscreen mode - LAlt-Enter, and that was it. The moment I did that the 2nd GPU kicked in.

    So on my system (Windows 8.0 x64), it would appear that when I click the the DRIVE button and the track loads ups you are sitting in the pits, the new screen has actually lost focus. As it has lost focus, the system thinks I am not in fullscreen mode, and cuts the no.2 gpu ready for desktop use.

    Every time I load up a track, I click the Assetto Corsa screen, and hit LAlt-Enter to enable crossfire

    If I don't click the screen first, LAtl-Enter will produce an error sound, proving that Assetto hasn't got focus yet

    Below is my current forced CF profile

    [​IMG]
     
    • Like Like x 1
  7. William Wester

    William Wester
    Premium Member

    With the latest beta drivers CrossFire always works for me - also monitor with MSI Afterburner.
     
    • Like Like x 1
  8. i guess it only works when full screen :/
     
  9. I dont know if you resolved this but i had a few problems but if you change from full screen and back to fullscreen always works since try to cap the frames to your refresh rate can do it in the game now or with afterburner makes everything in sync no steering lag i had 120fps with crossfire capped at 62 stays there always now