• You don't get fast in order to take part in club races, you take part in club races to get fast!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. #GiveAwayFriday. Win a copy of F1 2017 - The Game. Click here to join.

Cross track problem, give me cut track warning

Discussion in 'Bob's Track Builder' started by catboy, Dec 16, 2009.

  1. catboy

    catboy

    Messages:
    75
    Ratings:
    +4
    Hi all

    I make a track with cross track, i make a bridge to cross them.

    When test the track in rfactor and cross the bridge ( up level) give me cut track warning. any help..?

    sorry my english..
     
  2. mianiak

    mianiak

    Messages:
    578
    Ratings:
    +16
    A race line issue I think, try by clearing all AIW and re-append it, if it still fails, try doing the AIW manually.
     
  3. catboy

    catboy

    Messages:
    75
    Ratings:
    +4
    I will try

    Thanks for help, i will try to clean..
     
  4. catboy

    catboy

    Messages:
    75
    Ratings:
    +4
    Cross track

    I remove the Driveline and Append a new one..

    And the result is like image:
    [​IMG]

    If i move the point the line is in level but no Corridors.

    [​IMG]

    Any solution in BTB?? or i must edit the Driveline with AIW editor ?

    sorry my english
     
  5. mianiak

    mianiak

    Messages:
    578
    Ratings:
    +16
    Yep, you will have to use the AIW Editor from ISI. You will have to clear all and do everything including pit's garages, grid etc from scratch. Make sure to back up that AIW file too, otherwise if you edit the track and export, it will overwrite it.
     
  6. RT1971

    RT1971

    Messages:
    96
    Ratings:
    +0
    Ok this is just a theory, I have not tried it.
    Would it be possible to place a wall on its side just under the bridge wider than the road under the bridge and wider than bridge to stop BTB extending driveline and corridors to above track???
    If it works leave the wall and set to not render.
     
  7. Satangoss

    Satangoss

    Messages:
    110
    Ratings:
    +2
    RT1971's tip could be worth. I'd test it.

    In any cases, I guess this issue could be fixed manually. Just check in BTB what X and Z coordinates of the AIW's point which are being placed at wrong position (on the bridge).

    Now, I'd look for this waypoint into yourtrack.AIW file, for example:

    wp_perp=(your X coord,ELEVATION,your Z coord)

    You may correct the Y coordinate (elevation) by hand. The same you'll need to do with corridors, looking for the lines which contain:

    wp_dwidth=(...,...,...) and wp_path=(...,...)

    There is a deeper explanation of those lines into into ISI' AIW files.

    There's a lot of things which can be fixed by using only Notepad in Rfactor files. I think it's easier than recreate all AIW itens using ISI AIW Cam Editor, which is not very easy to use.
     
  8. catboy

    catboy

    Messages:
    75
    Ratings:
    +4
    thks all

    Thanks all for the replys


    The track have walls in two sides, i just hide.

    I think the solution is using AIW editor, but is not easy.


    The Notepad solution i think the worse solution, but works.. :)
     
  9. Eric Tozer

    Eric Tozer

    Messages:
    301
    Ratings:
    +1
  10. catboy

    catboy

    Messages:
    75
    Ratings:
    +4
  11. Eric Tozer

    Eric Tozer

    Messages:
    301
    Ratings:
    +1
    Try unchecking BTB ground on your terrain in that area under the bridge.
     
  12. catboy

    catboy

    Messages:
    75
    Ratings:
    +4
    YES the solution is unchecking BTB ground in terrain in that area under the bridge.!!


    Thanks all for helping
     
  13. Erwin Greven

    Erwin Greven
    retired from this site. Premium

    Messages:
    1,518
    Ratings:
    +256
    How do i do this?
     
  14. R Soul

    R Soul

    Messages:
    958
    Ratings:
    +190
    Select the pieces of terrain, go to Properties and you'll see some options in there.
     
  15. Frédéric Ducommun

    Frédéric Ducommun

    Messages:
    39
    Ratings:
    +0
    I have the same kind of problem on Vitus track. My solution : when I want to export the AIW, I remove the part of upper track that make's the AIW tube is juming (sorry for my bad english...). So the under AIW tube is good, but the upper tube is not, it's falling from upper to under track. After that, I build the part of track I have removed, and export, only the 3D. Then I have to go in the ISI AIW Editor, only to build this small part of upper AIW tube, the function is "smooth path". A little bit complicate, but it works.
    I have an idea, for the next time I will have something like that. Instead of make the upper track with track tool, I will make this little part with a wall. But I never try, so may be it's not working.
     
  16. Erwin Greven

    Erwin Greven
    retired from this site. Premium

    Messages:
    1,518
    Ratings:
    +256
    Sadly i do not understand exactly how i can solve the problem with the terrain options.

    circuit..JPG
     
  17. Eric Tozer

    Eric Tozer

    Messages:
    301
    Ratings:
    +1
    Try unchecking BTB Ground on your track (see pic)

    BTBGRND..jpg
     
  18. Erwin Greven

    Erwin Greven
    retired from this site. Premium

    Messages:
    1,518
    Ratings:
    +256
    But then the problem is that the upper AI line will drop on the bottom track. Maybe a sollution could be to have two tracks: 1 normal closed circuit and 1 open track part. Then uncheck btb ground of one track.
     
  19. Fabio675

    Fabio675

    Messages:
    6
    Ratings:
    +0

    aiw bridge crossing

    Hello,
    I also have the same problem.
    Did you manage to solve it?
    Thank you very much!

    [​IMG]
     
  20. Lee Knight

    Lee Knight

    Messages:
    956
    Ratings:
    +242
    Just curious, has anyone tried holding the 'Y' key & trying to move the AIW control point down to the desired surface?
    Like I said, just curious....