• "Mwoah" - Kimi Räikkönen
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. Dear Guest. Follow RaceDepartment on Twitter, Facebook, Instagram, Twitch, Steam and YouTube.

Crackling audio problem

Discussion in 'Assetto Corsa' started by Billy Pilgrim, Jan 21, 2017.

Tags:
  1. Billy Pilgrim

    Billy Pilgrim

    Messages:
    673
    Ratings:
    +101
    Hey
    I have been getting that crackling audio problem that I had a few times already and fixed. Happens when I'm near another car (with Fonsecher's sound and maybe all sound) on the track. I remember fixing it by re-defining some sort of audio channel parameter as 512 maybe.

    Can anyone point me in the right direction? Where is this file I previously found then lost?

    Thanks for any help
     
  2. Strikeman

    Strikeman
    Premium

    Messages:
    18
    Ratings:
    +5
    Turn the master volume down to 8. Thanks!
    \SteamLibrary\steamapps\common\assettocorsa\system\cfg audio_engine.ini
     
  3. Ross Garland

    Ross Garland
    A legend in my own mind... Staff Premium

    Messages:
    5,759
    Ratings:
    +2,243
    That's the max channels setting. The first two Fonsecker mods say the parameter is in a file called audio.ini, which I have in both the main CFG folder and in My Documents. The parameter doesn't appear in either file, so I suppose it would need to be added manually. Perhaps under the "Settings" section?

    However, the second two Fonsecker mods say the file is called audio_engine.ini, but that file doesn't exist for AC anywhere on my system. Others (Like Strikeman above) seem to have it though. Most odd.
     
    • Like Like x 1
  4. Keith Gregg

    Keith Gregg
    CAUTION - SLOW VEHICLE Premium

    Messages:
    266
    Ratings:
    +97
    Aye...it is there in my steam/assetto folder...always has been...its one of the first things I change after a reinstall/update.
     
    • Like Like x 1
  5. Ross Garland

    Ross Garland
    A legend in my own mind... Staff Premium

    Messages:
    5,759
    Ratings:
    +2,243
    Meh... good job I don't have crackling sound then I suppose!
     
  6. Dirk Steffen

    Dirk Steffen
    Porsche Factory Jackass Premium

    Messages:
    626
    Ratings:
    +340
    Thanks a lot for the pointers guys - will try it out (very bad crackling here, especially when watching a replay from the start with the entire field of cars).
     
  7. Andrew_WOT

    Andrew_WOT

    Messages:
    191
    Ratings:
    +23
    Drop master volume as suggested, after recent FMOD/sound update some AC mixes are just too hot and clipping, esp. with lots of going on like start of the race. I am running 0.6 at the moment.
     
    • Like Like x 1
  8. Dave_6

    Dave_6
    Premium

    Messages:
    289
    Ratings:
    +115
    Glad someone posted about this as I have the same issue.
     
  9. Dirk Steffen

    Dirk Steffen
    Porsche Factory Jackass Premium

    Messages:
    626
    Ratings:
    +340
    thanks Andrew, I tried yesterday to lower master volume in the settings and to set audio to 512 instead of 256 in the audio engine file.

    It was fine for a few sessions but came back with a vengeance.
    I didnt have enough time to investigate further but will experiment in time.

    Its too bad really that such bugs are creeping in with the general very high qualiy of AC :-(

    As a side note - I have used the Fonsecker Porsche 911 GT3R sounds for the first time for a few Nordscheife races and man I cannot believe why he isnt on a Kunos payroll.
    The man is a genius!

    These are by far the most beautiful sounding noises I have heard from a simulated 911 yet.
    It sounds alive, viscious, angry, sensitive to input, just glorious!