1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
Dismiss Notice
Like RaceDepartment on Facebook.

Corrupted Wheel Profile??

Discussion in 'F1 2015 - The Game' started by Lazarou, Jul 10, 2015.

  1. Lazarou

    Lazarou
    Premium Member

    I wonder if anyone can help. I got some sort of wheel settings configured between the Logitech Profiler software and the game for my DFGT, then the game caused a catstrophic crash of my game/pc. Now when I go to use logitech custom profile in game out on track the steering and button assignments are all wrong and I cannot steer or accelerate on my CSR elites.

    If I then delete the profile in the Logitech software it then recognises the wheel again but then I have no custom settings I can use like wheel rotation etc.

    Is there anyway to delete my profile and or wheel settings in game and start again?
     
  2. Graham Laing

    Graham Laing
    ...... mostly harmless Staff

    In the MyF1 menu, isn't there a option the create a new game save?

    That might reset everything.

    Otherwise you could delete your profile in Steam, make sure Steam Cloud is disabled for this game, so it doesn't put the old profile back into the game

    YourSteamInstallDrive\Program Files (x86)\Steam\userdata\YourSteamID\286570\remote
     
    • Like Like x 1
  3. Lazarou

    Lazarou
    Premium Member

    Thanks for the info Graham I will try deleting my profile later when I get home. I did try a new save but the same issue still occurred.
     
  4. Graham Laing

    Graham Laing
    ...... mostly harmless Staff

    I noticed that all the old actionmap .xml files for each wheel are now gone.

    If you remember, in all the previous games, if you edited your wheel's xml file, you had to start your game via the keyboard (not the wheel), so the default controller became the keyboard. Then you re-selected your wheel, and this forced the game to re-read that edited actionmap .xml file and then store the changes internally in your profile.

    I am now wondering that if you start F1 2015 with the keyboard, perhaps with the wheel disconnected, so the keyboard becomes the default controller, then close the game. Now plug in your wheel and re-start the game either using the wheel buttons to get into the game (if they work), or re-selecting the wheel once booted (if the buttons didn't work on boot), it might now be reset.

    Just a theory :)
     
    • Like Like x 1
  5. Lazarou

    Lazarou
    Premium Member

    Very strange, before I deleted anything I had one more go at making a profile in the Logitech software. It let me edit it this time in the game. So I go to test it in time attack and discover the pedals are doing the opposite if what the should. So I invert them then everything is okay, I go back in the pits change the setup of the car a bit, come back out on track and the brake is now reversed again, so I reverse back to normal. I then go back to the main menu and select a different track, get on track and the accelerator is reversed again, so I then reverse it back to how it should. Been okay since.

    Bizarre shenanigans! Thanks for replying Graham appreciate it.
     
  6. Graham Laing

    Graham Laing
    ...... mostly harmless Staff

    Similarity?

    Paul I've just fixed my G27 for F1 2015, it was linked to the same problem that I had with pCars, but had forgotten about.

    I created a pCars profile in my Logitech software, but my pedals were not working correctly, even though my pCars profile had them set to 'not combined' i.e unticked.

    I discovered that the Logitech global profile had them selected as combined (I don't know how). The upshot being that my Logitech pCars profile wasn't loading, so the global profile took precedence, screwing up my pedals in pCars (combined).

    Today my wheel wasn't working correctly, and I had created a F1 2015 Logitech profile. Again this profile wasn't loading and the global profile took over. In the global profile my rotation is set at 540 degrees, and this game needs 360 degrees for 1:1.

    I couldn't get around corners very well, a 90 degree turn of my wheel, looked roughly like 45 degrees in game, and felt like it too :)

    I had to force the profile as the persistent profile to get it to work, not just select it as the current profile.

    Also shutting down the Logitech Software fixed it too, just using the Windows settings which I adjusted to @ 360 degrees. This was the quick fix but not ideal when you have many games

    Cheers :)
     
    Last edited: Jul 10, 2015
  7. You can press both middle red buttons on the Shifter unit of the G27, together with the left button of the fout buttons on top, that automaticcaly sets the wheel to 450 degrees, Then wheel rotation works fine for 2015. You dont have to change iT in profiler
     
  8. How to set Logitech profiler for g27?
     
  9. Graham Laing

    Graham Laing
    ...... mostly harmless Staff

    Thanks, that's useful info, but this game requires a 360 degree rotation if you want 1:1 ratio with the in-game wheel

    http://www.racedepartment.com/threads/f1-2015-steering-wheel-controller-settings-list.105081/