• “Just being a mediocre driver has never been my ambition. That's not my style” ― Michael Schumacher
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. Have a chance to win a copy of F1 2017 The Game (PC) by following RaceDepartment on Twitter, Facebook, Instagram, Twitch, Steam and / or YouTube.

Controller Problem back :( (control sensitivity and deadzone settings do nothing)

Discussion in 'Stock Car Extreme' started by Spinelli, Sep 24, 2015.

  1. Spinelli

    Spinelli

    Messages:
    636
    Ratings:
    +154
    It's happening again and I can't fix it. Adjusting the sensitivity and the deadzone sliders don't do anything. Sensitivity makes a big difference for me and I can easily tell me my pedal's sensitivities are not to my liking.

    I tried loading a saved controller profile then adjusting the sensitivity/deazone. I tried restarting the game and going straight to adjusting it without loading a controller profile. I tried remapping my controls. I tried going out on track (to maybe sort of "activate" the controls) then escape back to the controls section. I also saved and then loaded the controls with the sensitivity and deadzone sliders all adjusted but even that doesn't work; the controls still behave as if I have no deadzone (I tried 70% deadzone in order to easily notice if it's working). Nothing I tried works; the sensitivity and deadzone sliders don't have any effect at all and the game is currently "baked" to use no deadzone regardless of what I have it set to - same with sensitivity.

    My pedals are the Fanatec Clubsport Pedals V3 plugged directly to PC and themselves work absolutely perfect. They show up as controller 2 in-game. My wheel is the Fanatec Clubsport Wheel V2 (w/ Porsche 918 RSR rim) and it shows up as controller 1 in-game.

    This is the second time this has happened to me.
     
    Last edited: Sep 24, 2015
  2. Lazarou

    Lazarou

    Messages:
    1,696
    Ratings:
    +1,015
    The only way I have fixed pedal issues is by creating a new controller profile. Which if you have button boxes etc like me is right pain in the arse.
     
  3. Spinelli

    Spinelli

    Messages:
    636
    Ratings:
    +154
    I did, but sensitivity and deadzone still don't do anything.

    Steering and throttle are both assigned to input X. The only difference is that steering is Joy1 and throttle (as-well as brake) is Joy2. Maybe the game is in-capable of applying sensitivity and deadzone settings to anything other than Joy1? I can't see that being the case though because I used seperate pedals for 99% of the time I've ever played SCE and it's never done this except one time a while ago.
     
  4. Fabio Rodrigues

    Fabio Rodrigues
    Reiza Studios Community Manager

    Messages:
    670
    Ratings:
    +421
    Our next version will have extra sliders for controllers that hopefully might help with that issue. I'm sorry you're having trouble.
     
  5. Spinelli

    Spinelli

    Messages:
    636
    Ratings:
    +154
    Great, thanks for the reply and good news. I'll report back if I make any other findings regarding the issue.
     
  6. Niels_at_home

    Niels_at_home
    Reiza Studios

    Messages:
    224
    Ratings:
    +313
    I've seen somewhat randomly that controller and user data isn't saved in the rfactor (thats what I had it happen on, not GSC) folder but in the 'my documents' folder somewhere. Something with user account control and/or having installed the game in 'program files'..

    No idea if this can happen but perhaps your files are stored not where you think they are?