• "My mind is always racing." - Justin Bieber
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. Dear Guest. Follow RaceDepartment on Twitter, Facebook, Instagram, Twitch, Steam and YouTube.

PC clubsport pedals not recognized

Discussion in 'Project CARS' started by musco, May 28, 2015.

  1. musco

    musco

    Messages:
    1
    Ratings:
    +0
    I'm using The thrustmaster T500rs and fanatec clubsport V2 pedals.
    The pedals are doing nothing,mapping is also not working and stays tight on U.
     
  2. Lancey

    Lancey

    Messages:
    124
    Ratings:
    +7
    When I mapped my club sports pedals the sliding bars didn't work but the pedals worked when I tried them out in a race. Had a go at mapping them a second time and the sliding bars worked ok. I'm using the T300rs wheel. All I can say is keep trying.
     
  3. Chris Harris

    Chris Harris

    Messages:
    56
    Ratings:
    +22
    I might be wrong but you may need to set your control type in the settings to t500rs + seperate pedals and not t500rs + combined pedals.
     
  4. SnappyDEe

    SnappyDEe

    Messages:
    927
    Ratings:
    +304
    Also, be sure to assign the pedals (just like mapping the buttons on the wheel) and then calibrate them.
     
  5. Brandon Wright

    Brandon Wright
    I may not be fast, but I'm wide! Premium

    Messages:
    3,959
    Ratings:
    +1,620
    I had the same problem at first, and this fixed it. Map the pedals just like you would a button for "look left" or "change camera", then go the calibration page and they should work.