1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

career restarts on pc reboot..please help!!!

Discussion in 'F1 2012 - The Game' started by deepanshu, Dec 3, 2012.

  1. hello...i recently installed f1 2012..after findin pro a bit 2 tough for me..i edited the data base using RDE...the game ran fine..i completed melbourne but when i restarted my pc...it again asked me to create an autosave file...has anyone else been hit by such an issue? how to fix this??...please reply soon..i want to play the game but cant...and i dont want the original database back because i simply dont enjoy the game with defendin thru out the race
  2. someone please reply...everytime i start my pc the career restarts..means game progress is gone...i restored the original databse ...still problem persists
  3. try to verify integrity of game cache
    • Like Like x 1
  4. Yes, in Steam, verify integrity of files. THEN turn off cloud synchronisation and even better, if you only play offline, switch to Steam off line. It will then save ok.
    • Like Like x 1
  5. Just a dumb question, how to switch steam offline? If I do this will this solve this >>> When I play the game for the first time since booting up my pc the game runs fine but after I exit the game and try to play again it takes forever to start the game running again, just a little screen from steam saying "preparing to launch F1 2012..." I have to restart my pc or log-off then log-in again to load the game again
  6. Thanx a lot Keith...it saves properly now after verifying integrity of files :)
  7. yup..did tat..wrks gr8 now ..cheers
    • Like Like x 1
  8. In steam menu just select 'go offline', then confirm 'restart steam in offline mode'.
    The 'preparing to launch f1 2012' mesage might happen once more but after that it should start quickly each time.
  9. Thanks man, it worked!
    • Like Like x 1
  10. Glad to help :)
  11. Bumping this thread for the same reason, but still have not found a fix for it

    I've had this problem for a long time now, and the game only restricts me to Quick Races and I have to repeat the set-up of my controller and all other settings each time I resart my game after Steam is closed and re-opened. So if I save my profile, exit the game, don't close steam, then go back into the game, my profile is still there. But if I save my profile, exit the game and then close down steam, then go back into the game again, it never recognises my old profile and asks me to create a new profile each time. So obviously once steam and my laptop are shut down, when I restart them again and go back into the game, I need a new profile each time and my old profile is just "lost" somewhere. Very frustrating and annoying, as I have to reset my controller each time (it's this bug which has put me off buying a wheel for now), but also have tp reset the game settings, osd, audio, and of course have to forward through the YDT each time I play, which is annoying and time consuming.

    I've tried disabling autosave, disabling steam cloud sync and have verified my game cache several times now, but still have the same issue every single time. Luckily I've backed up all the mods I've downloaded the mods I was using on quick races, so I can always put them back in, but this issue is stopping me from starting career mode, and has now long before I found this forum. Before I re-install my mods, I want to ensure that I can fix this profile save bug first. But now, after researching this forum and steam forums, I'm out of answers as to what to try next, apart from re-installing my whole game, which I seriously want to try to avoid doing.
    :poop: :mad::unsure::(:thumbsdown:

    Sorry for the quality of the video I've done and attached below showing this issue clearly, as it was taken from my mobile phone, but it shows nicely the problem I'm facing with regards to this. Also shows nicely my Ferrari Testarossa and Lamborghini Contach cars on my TV/laptop stand ;) .

    Any ideas guys, other than re-installing my game again, starting from scratch and hoping this bug doesn't happen again? I'm currently out of any further ideas as to how to fix this.
  12. I dont think you are saving anything..

    As you can see, when it saves you can see the word autosaving.If you've done everything you say then maybe a clean install would help.
    Install the mods again and find the one causing problems.
  13. Dimos is right, it is not saving. This problem was happening several patches ago, but it was certainly fixed on mine in later patches (though I do not go online now just to be sure).
    Go back online, verify integrity of all files, then switch to offline before doing anything else (and certainly BEFORE starting the game).
    Then before reinstalling any mods, check the game. I think you will find it is saving ok.

    After that, install mods one by one, but keep checking.

    Maybe it is possible you forgot to go offline last time before checking the game saved? It would appear to work, but then when you switch to offline it would break again. I don't know. But my earlier advice is still the same. If it is a clean install and then switched to offline (BEFORE you try the game again) , it should save fine. Only then start adding the mods and see what happens. Good luck :)
    • Like Like x 1
  14. Thanks for the responses and suggestions, Dimos and Keith.

    I searched high and low for answer to this, and finally I may have found someone with the exact same problem that I have. Looks like there may be no fix for this, but a viable workaround instead.

    Have at look at this topic on the codemasters forums : http://community.codemasters.com/t5...e-keeps-forgetting-profile/m-p/128488#U128488

    I'm going to try what was suggested in that thread, and if all else fails beyond that workaround, I'll consider a full re-install of the game and start from there.

    Once again, thanks for your replies and suggestions guys.

    EDIT: Fixed it today after 2 hours mucking around through trial and error, but not using the workaround suggested in that link I posted.

    Seems like I hadn't properly logged out of Steam at some stage a long time ago, and after mucking around in Steam unticking a few boxes here and there, I was able to find this out. So I logged out, logged back in online, re-disabled steam sync cloud service, logged out of Steam again, logged back in offline and all settings were good now. Started F12012 and set up my controller, OSD, Audio etc and a new profile and completed day 1 of the YDT again. Ensured autosave was off. Exited and saved manually. Exited the game, exited Steam. Shut down my laptop, restarted, plugged in my controller again, started F12012 and lo and behold, my new saved profile was still there:D So the problem is now resolved.

    Now to buy a wheel tomorrow, and another HDMI cable to connect my laptop to my TV, and maybe some good recording equipment depending on the price:p
  15. That's good news. I would still save the userdata folder regularly to be on the safe side. At least you can get back to where you were if it happens again (though I must admit I have not had to use my backup for ages thankfully).