1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Can't move object?

Discussion in 'Bob's Track Builder' started by intorios, Jun 23, 2012.

  1. Hi guys,

    I've created a track using Google Earth, imported it in BTB, all works fine. Then I created the surrounding terrain in Sketchup, which I can import in BTB as an object no problem. But I cannot move this object. No matter what happens, I can't select it, only by using the select all function and as soon as I try to move it with the mouse, the selection goes back to 0. This is driving me insane, all I want to do is line the terrain object up with the track! Please, can anyone help me?
  2. first thing i thougt of is: are the polys of your terrain object facing up? maybe because they are "facing down" you cant click on it? if you select monochrome planes or something like this instead of textures in sketchup, the white side of the planes are the "right side" which has to face up, the slightly blue one faces down. you only collide or drive on the white side, never the blue!
    second thought: you definetly need some terrain from btb under the origin fo youre terrain-object to move it. the origin alsway ahs to be above/below "btb-ground", meaning terrain created by btb.

  3. Thanky for your suggestions neteye. Unfortunatley, it's just gotten weirder. I tried again and this time I was able to move it! I lined the terrain up with the track in birds eye view. Then I went to a side view, unchecked the "rest on ground" box and tried to move it up a bit, as the track was still floating above the terrain. But now the same problem is happening again, I can't move/select the terrain.

    Edit: tried again: it seems I have to go very cloes to the terrain in order to move it - does this have something to do with the LOD out?
  4. BTB probably works out the distance between where you click and the centre of the object, and only selects an object it the distance is small enough. That works fine for small objects but not for large ones. In sketchup you could try repositioning the object so one of the corners is at 0,0. Once imported into BTB, you might be able to zoom in on that corner before selecting the object.
  5. I was also trying to import the terrain as per this video aswell

    I experienced the same problem you've got, in the end I worked it out that the terrain was to big for btb's working area. soon as I used a smaller area/object, it worked and I could move it around and position it.
    Then I hit a problem after exporting to rFactor which the video doesn't seem to mention anything about. BTB can load and export it, but rFactor just closed without an error message when I tried to load the track. Cant remember If I resized all the textures at this time.

    I also like to point out as I found out the hardway, you cant move the axis on the imported terrain, so the little red,green,blue adjuster icon is in the middle of the very first area you grabbed in sketchup.

    I will one day re visit this method of creating the terrain, and figure it out but not yet.
  6. The objects centre must be over BTB land or track, not over empty space. I had same issue once. But you need to be close up to see the red dot, and far away to see where you need to move it. So it is a bit of a pain. Best way is to place it in it's correct position in Sketchup.
  7. I read what you said first. If you select more than one object to move ( you selected all )
    you need to press and hold the left shift key down while moving all. if you dont , only the object the mouse is over will move. if you want to move high or low you need to press shift and Y. you can move from any height , just select move in edit and click left mouse button and hold over object to move. I have moved object from one side to the other without having to zoom in to see the dot. also if nothing is selected you can hold Shift key and hold left mouse button and circle around a group of objects then still pressing the shift key move that group you just selected.