• “Just being a mediocre driver has never been my ambition. That's not my style” ― Michael Schumacher
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. Dear Guest. Follow RaceDepartment on Twitter, Facebook, Instagram, Twitch, Steam and YouTube.

Can't Map "Real Automatic" Transmission

Discussion in 'Euro Truck Simulator 2' started by Roger Snead, Jan 5, 2015.

  1. Roger Snead

    Roger Snead

    Messages:
    424
    Ratings:
    +62
    Hello to all. I did a search on this forum, but still a bit unclear. I am hoping someone will take the time to explain in detail, but with simple terms, as I am a pc noob. Thank you in advance.

    I am using a CSR Elite wheel with Windows 8.1. I do not have a working H-gate shifter. (just broke recently) I want to use "Real Automatic" tranny, not "Simple Automatic." The problem I am having is ....if I remember correctly, the mapping for this option ("Forward" and Reverse" )is in the Keyboard menu, but the game allows you to map a button or paddle shifter on the wheel. However, I have to physically hold any button or paddle down to keep it in gear. I can actually see on the truck's interior dashboard the gears changing. Same for Reverse. As soon as I let go of the button, it goes into Neutral, and I see "N" on the dashboard.

    Please.......How /what button, key or paddle can I use without having to HOLD DOWN the button (or paddle,if mapped that way) to keep it in gear? I almost have it sorted , because I see that it does actually work, but I need to map this feature with either a keyboard key, or wheel button, that does not require me holding down a button or paddle.

    I absolutely love this sim, as it is oddly addicting in a way. I never thought I would enjoy this sim so much. Like I say, I am quite a noob with pc sims as I am basically a console player, but am wanting to convert and learn pc. Been saying that for years.....hehe

    Please, if one could help me with very clear and easy to understand instructions, I would be most grateful. Thank you.
     
  2. Bazooka_Joe

    Bazooka_Joe
    Best of the worst, sometimes worst of the worst. Premium

    Messages:
    242
    Ratings:
    +136
    Not sure if this is not a bug. Real Automatic setting used to work not so long ago perfectly fine. After installing one of the updates I'm experiencing exactly the same issue on Logitech DFGT where I need to hold the gearstick to keep it on gear. Switched to Manual gearbox but that's not ideal due to quiet engine sounds. I'm hoping too, that there's a solution to this somewhere...
     
  3. Roger Snead

    Roger Snead

    Messages:
    424
    Ratings:
    +62
    I have it sorted..........maybe it will work for you as well. ;) I saw the solution posted last night while doing a Search on the ETS2 Steam forums.

    I mapped the "SHIFT" (Drive) and "CONTROL" (Reverse) keys. I tried other keys, but no go, you had to hold them down. I was going mad trying to get it sorted. :confused: