1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
Dismiss Notice
Like RaceDepartment on Facebook.

Can't load Steam Version RF2

Discussion in 'rFactor 2' started by M4RTYMCF1Y, Dec 13, 2015.

  1. Hello, my GTX 780 GPU died just as Rfactor 2 came out on steam. I only managed to play the game using integrated intel HD Graphics, but the game was at least playable.

    Yesterday I got a new GTX 970 to replace my dead GTX 780 but now I can't get Rfactor 2 to load at all. It loads the small splash screen and then just goes to a black screen. Sometimes I can hear the menu buttons sfx if I move my mouse but I cannot see anything on screen.

    I tried to unistall the game and re-install but it seems that not all the files get deleted. For example I unsubscribed to all the workshop items after reading that some wonky mods can cause the black screen but the mods are still listed in the rfactor launcher (despite deleting the folder as well). My other games are fine, steam and non-steam games.

    It's super annoying that I can't get the game to load. The ISI forums are a ghost town it seems and I'm stuck as to what to do.

    I've tried selecting various resolutions, windowed / fullscreen mode, clean install etc but the game just does not want to load. Has anyone else who has had this issue share how they fixed it or give me a clue how to troubleshoot it please?

    (I'm on Win 10 Home 64bit if that helps. It worked under Win 10 on the integrated gpu fine)

    Many Thanks.
     
  2. Issues such as this are probably best directed to support, but I'd start by making sure onboard video is disabled in bios and a clean install of drivers/runtimes.
     
    • Beer Beer x 1
  3. Ari Antero

    Ari Antero
    Premium Member

    I think it is best do do clean install with DDU.
    You find DDU and user guide here : https://forums.geforce.com/default/...or-new-cpu-core-analyzer-updated-12-04-2015-/
     
    • Beer Beer x 1
  4. Stig Bidstrup

    Stig Bidstrup
    Blip ! The Throttle Premium Member

    I have tried this with Race 07 ( from steam ) since then I always install a clean install of Geforce drivers, when I update the graphic drivers, choose customize install when you install , then click the clean install option, I think that's the problem your having....
     
    • Beer Beer x 1
  5. Thanks so much to both of you, I didn't think of that! The game is now working and playable. Thank you for pointing me in the right direction.

    :thumbsup::thumbsup::thumbsup: