1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
Dismiss Notice
Like RaceDepartment on Facebook.

PC Can't get to move

Discussion in 'Assetto Corsa' started by Matthew327, Nov 23, 2015.

  1. UPDATE:
    PROBLEM SOLVED! NO FURTHER ACTION NEEDED!
    Thank you very much, RD community!


    Hey everyone,

    so I recently purchased Assetto Corsa to try and get to know the game a little, and so far everything works fine - until the moment I head to the track.
    As soon as I'm on track, the car just sits there and I cannot interact with it in any way. I can still change camera angles and all that, but the controls do not react. I can't steer or accelerate or anything else. (For now I only have my PC keyboard and a PS3 controller at my disposal since I'm only at the start of getting properly into virtual racing.)
    Any help with this would be greatly appreciated (and sorry if this has been handled elsewhere already).
     
    Last edited: Nov 26, 2015
  2. Benutzername

    Benutzername
    Online Martini Racing - Founder and driver

    Might be a stupid question for me, but just to be sure... :p

    When you are in the menu, under steering:

    Do these bars move when you press your button for braking etc?
    [​IMG]
     
    • Like Like x 1
  3. Did you calibrate your steering wheel and pedals? There is a configuration "wizard" you can use to calibrate you wheel/pedals.
     
  4. If you're using a keyboard to steer, then select keyboard in the controls menu, and also check the buttons needed to drive the car and change gears.
    And for gamepad, you need to select that gamepad option in the controls menu, otherwise the it won't work.
    There's no reason for the keyboard to not work with any car (also check the assists page in the summary tab, after you select car and track), but the PS3 controller might need some drivers or software so that it becomes compatible with Windows games. But try it in wheel/custom, and assign there the axis and buttons for your ps3 gamepad.
     
  5. As for my attempt with my PS3 controller, in the menu, the buttons work fine. Everything reacts as it should in the calibration window. Same with the keyboard.

    However, as soon as I start any session, the only thing I can do is change the camera angle (which means that the game reacts to my keyboard, but the car doesn't).
     
  6. Did you activate the "Combine with Keyboard Input" setting?
     
  7. Nope - gonna try that when I get the chance, thanks :)
     
  8. Sniper

    Sniper
    Premium Member

    This will be the issue
     
  9. Disconnect the controller, only let the keyboard and mouse. Btw, are you sure you didn't enable mouse steering in the keyboard game options? And what's the model of your keyboard? Maybe you could delete the controls.ini file from documents/assetto corsa/cfg, and then open the game to try again without changing anything. I think by default keyboard is selected in the controls page, and keep your gamepad unplugged.
     
  10. Unfortunately it wasn't - still can't move.
     
    • Like Like x 1
  11. Gamepad unplugged, controls.ini deleted and still no change.
     
  12. What's your keyboard model? Or try a different usb port. You could also try mouse steering, just select the option for it in controls, then you can control steering with mouse movement and pedals with mouse buttons. When on the track, Ctrl+M disables mouse steering to let you use the menu.
     
  13. Still no progress. The car just sits there, the camera spins around. I can switch to onboard, cockpit, anything, but I can't move.
     
  14. Wait, after you loaded to the track and click the Drive (steering wheel icon) button, the camera doesn't spin around the car any more. In fact when you load to the track, the game shows parts of the track and when you click Drive the camera is on or in the car.

    Do you see the left side red menu after you just loaded the track? The place where you see some info, setup change, etc.
     
    • Agree Agree x 1
  15. You solved this? In case is like I said in my post above, check your game or windows resolution. Or in Windows check if you zoomed the screen, where the optimal setting should be 100% zoom, not 125 or 150. Or if you have some 3D screen or projector, check its settings or disable it just to try out.
     
  16. So throttle does nothing, not even increase revs?
     
  17. Nope, don't see anything :/
     
  18. Nope :/
     
  19. Ok, there isn't actually any problem with the cars or your controllers/keyboard, but the problem is that you can't click the button that puts you in control of the car.

    Do you confirm that you can't see this menu on the left when you get to the track? My post above this one tries to give some tips about it. Because you need to click on that steering wheel button to gain access to the car. Though the camera buttons work, just not driving the car nor using the apps from right side.
    And what is your monitor? Maybe press the Auto button so it resizes.

    [​IMG]
     
    • Winner Winner x 2
  20. Confirm - I cannot see this menu. So perhaps it's a resolution problem then? Thank you very much, I'm gonna try different graphics options then (windowed mode perhaps) :)

    Update:
    THANK YOU! That was in fact the problem! I changed the resolution from 1920x1080 (my native screen resolution) to 1600x900 and now I have the menu on the side and I can access my car and get to driving... thank you again, @Radu Oros!
     
    Last edited: Nov 26, 2015
    • Like Like x 1