1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
Dismiss Notice
Like RaceDepartment on Facebook.

Build-590-Released

Discussion in 'rFactor 2' started by Simon Christmann, Mar 20, 2014.

    • Like Like x 1
  1. Gijs van Elderen

    Gijs van Elderen
    Premium Member

    Rel notes

    GRAPHICS:
    ————————
    Fixed bug with HDR lum histogram when in SLI mode
    Fixed 3D Vision problem with tire shader
    Added extended ambient shadows under cars
    Modified EnvReflections = Off mode to render only sky/clouds into ref map


    FEATURES:
    ————————
    Added "+memstats" cmdline option to output memory usage file


    BUG FIXES / OPTIMIZATIONS:
    ————————
    Fixed crash on MP lobby UI page
    Fixed an issue with duplicate mas names during packaging; incorporated mutex stuff into masBase to allow toggling of mutex requirement during mas object creation
    Fixed bug where 1st time running after fresh install keyboard and controller support will be disabled.
    Fixed a potential problem with upgrades that adjust gear settings.
    Fix issue where sometimes shadows were fuzzy in cockpit until you hit Insert three times.
    Fix for sidebars not clearing when exiting replay mode directly from control screen.
    Fix for issue where a vehicle is constantly loaded/unloaded in multiplayer when they have a special skin


    MODDING / PUBLIC DEV
    ————————
    Added "Copy To Clipboard" button to TTool.
    Fixed viewer.exe crash
    Corrected rFactor Mod Mode.exe UI
    Fixed lockup when mouse is moved in mod mode


    UI / HUD / Options:
    ————————
    Added a button to manually transfer loose livery file, so that you may update the server's copy or get the latest version of the livery stored on the server.
    Disabled Mod button if server and client version do not match.


    MULTIPLAYER:
    ————————
    Fixed +oneclick crash
    Fixed join button greyed out issue
    Message box shown if dedicated server is stated with oneclick but no mod is loaded
    Reduced likelihood of problem in non-race multiplayer sessions where vehicles that joined late would usually not load.


    CONTROLLERS / FFB
    ————————


    AI
    ————————
    Preventing driver database from growing much larger than it needs with duplicate entries
    Loading custom paths from the loose track directory (*.aip files contain info for a single path)
    Small change attempting to reduce AI tendency to stay behind a slower car.
     
  2. Stefan Woudenberg

    Stefan Woudenberg
    Premium Member

    double posted (release notes) :p
     
    • Like Like x 1
  3. Bez

    Bez
    All the gear, no idea...

    id love to see the changes myself but since updating to the latest build i can no longer even launch the damn thing, just drops to desktop after it tries to fire up.....any ideas on what my problem might be? i updated using the games built in updater as ive done in the past, tried restarting the pc but still the same problem where the game simply drops back to desktop upon starting...
     
  4. museumsteve

    museumsteve
    Premium Member

    Can you run the config?
     
  5. Bez

    Bez
    All the gear, no idea...

    yeah the config is showing the usual settings that i normally run

    edit: got it working by setting the resolution to 800x600, once i got into the game i was able to turn the resolution back up but now i get a strange crash to desktop whenever i alter video settings, luckily the settings are saved when i restart rf2, im thinking a nice clean install might be in order as something is obviously not happy. On a side note the game seems to be running better than ever for me, getting 120-160fps with all settings on max and in game aliasing set to 8, also think my micro stutters have gone with the latest build
     
    Last edited: Mar 21, 2014
    • Like Like x 1
  6. Calum McLure

    Calum McLure
    Did ye, aye? Premium Member

    It always crashes for me when I change car on the server then click "race", done it 3 times in a row.