1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
Dismiss Notice
Like RaceDepartment on Facebook.

BTB - Rfactor export / texture quality ??

Discussion in 'Bob's Track Builder' started by ThomasFrank, Sep 6, 2011.

  1. Hey guys,

    I built my first BTB Track and now I have a question.
    When I build the Track in BTB the texture quality looks very nice but when I export it to RFactor the whole textures look really bad. My graphics settings are high so that can`t be the problem. I hope you now a solution to improve the graphic quality in the game.

    Thank you very much ;-)

    Thomas Frank
     
  2. Are your graphics settings on High or Max? AFAIK, High uses a lower mip map than Max and will give you a lower texture quality.
     
  3. If you are using your own materials, make sure the Mip Bias value is negative. -4 is suitable for a track, maybe -2 for grass (takes some experimenting).
     
  4. Also Ive noticed, distance can of lap/circuit can have an effect on MIP MAP requiring an even greater negative value....
    33km track requiring -4 for grass & -5 for road (Haywood track pack road texture) & -6 for tree wall....
    R Soul IS right, experimenting IS the go & not being afraid to use numbers that DO work (even if they seem somewhat high) is the go- if they work for you then just ask if others can then test -after all, everyone's system is different & faults may not turn up in your own that others may have & vice-versa.....
    Most of us need to do this,
    Good Luck!
     
  5. Hey,

    thanks for the quick answers ! ;-)

    Where can I find the Mip Bias values ?
    I think thats the problem - my graphic settings are max
     
  6. The first place you should check is Venue Materials ([​IMG]). Select a material, then the Textures tab, then you'll see some more tabs, depending on the material settings: Diffuse, Bump, Specular, Multiply, Add. Mip Bias is one of the fields at the bottom.

    If you've added your own materials using XPacker, Mip Bias is in the Materials section, under Diffuse, Bump etc.
     
  7. Make sure your textures has mipmaps in the first place. Some DDS i've downloaded hasn't got any mipmaps and they look rubbish ingame unless you're close enough. If the textures are in PNG or JPG then there's no mipmapping done in advance, that means extra calculations for GPU as it has to do basic scaling in realtime.. The algorithms used inline are really simple, not even close what is done in offline edit so the more the graphic card has to scale textures, more blurry they become. When preprocessed ie. mipmaps inserted, the quality is exponentially better. That is how i have understood it, correct me if i'm wrong, please. The explanation fits to my logic and results anyway.
     
  8. ebrich

    ebrich
    Premium Member

    Well I have to thank you all. I've spent ages cursing the problem of shimmering grass texture when making my own blends between differing terrain textures, on a flattened wall(Evo). Having read R Soul I did mess around with the Mip Bias. Made no difference. Opened the original file (rural Ozzy) to find the textures had Mipmaps of 10. Therfore resaved all my textures with, Generate mip maps at 10, and no more shimmering. Can't life be just great sometimes!
     
  9. Thank you all ! It works my texture quality is perfect and my track is nearly completed !
    "Lost Heaven Raceway" from the game Mafia 1

    thanks a lot - what a great community ;-)