1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Bob's Track Builder track doesn't work

Discussion in 'Racer Tracks' started by Lipton, Jan 22, 2011.

  1. I made a quick road in BTB and then exported it with the built-in exporter. I load up Racer, select the track from the list, click to start the drive and after the loading bar completes it kicks me back to the front end. No idea what's wrong... It worked fine before...

    I`ve uploaded the track and the Qlog I get.

    Track: http://www.megaupload.com/?d=CT9VL6PR

    Qlog: http://www.megaupload.com/?d=K9Z67VYP

    Thanks in advance.
     
  2. Stereo

    Stereo
    Premium Member

    I can't get the qlog, but in recent versions it strictly enforces car/track versions, so you need version=090 or it'll just kick back to the menu. BTB probably wouldn't do that automatically.
     
  3. Okay, thanks. Will try that.


    EDIT: Added the line, however it still fails :(

    EDIT2: "nests too deep" seems to be very common in the Qlog after trying to load the track...
     
  4. you need to copy the special.ini from carlswood and adjust to your track ;D
    Later , you need to add spline and positions with trackEd ^^.
    And delete some 1KB models.
     
  5. Okay, did what you said, however it still doesn`t work. Now instead of being kicked to the front end, racer crashes :D. Did you get it to work?
    If yes, can you please reupload it and post the link here. THanks!
     
  6. Can you upload the BTB project?I think I know what is the problem,just to test.
     
  7. Be sure you don't have any other Xpacks loaded. I've found some such as the Great Britain (RBR) will cause Racer to crash.

    I was an early supporter and beta tester for BTB, I pushed Piddy and Ruud to support Racer in BTB. Unfortunately just as we started to get basic support Piddy had to quit updating BTB. Still it is a useful program. At one time we had someone working on a similar project specifically for Racer but it too seems to have fallen by the wayside.

    Alex Forbin
     
  8. Have you declared the grid positions?At this am I thinking.
     
  9. BTB does that automatically. The only basic function it doesn't do is generate cameras, but they won't cause a failure.

    Alex Forbin
     
  10. Alexander Knoll

    Alexander Knoll
    NEVER GIVE UP!!

    öhm...do you know how many Objects do you use?.....
    ...this is the Qlog i got from Tracked.....

    EDIT:
    take a look to the special ini.....there are any bad code parts...

    example:
    ...i'm sure that is one of many problems....

    Edit2:

    .....44x gridpos 0?!...

    Edit3:

    ...got it....

    screenshot024.jpg
     
  11. Looks like it needs a sky dome and more gound.
     
  12. Alexander Knoll

    Alexander Knoll
    NEVER GIVE UP!!

    oh...yes Bob...sure sky is needed...but at first, i think, Lipton should remove 2500 from this 5k of objects......
    Ok, what have i done to got it working.....
    1, use the special ini file from Carlswood NT.....
    2, defined a new gridpos0....with tracked...
    3, remove this flags=774 thing....to flags=6....
    4, the lod thing was removed from tracked.....
    5, at the moment i call this file in the geometry ini i get a crash......
    ...not sure why....
    The resoult looks like this.....
    screenshot025.jpg

    ...and here is the file:

    DivShare File - RockyRoad1.7z
     
  13. Thank you, will try this asap.