1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Black Screen

Discussion in 'Richard Burns Rally' started by Caramidaru Andrei Bogdan, Dec 19, 2012.

  1. Caramidaru Andrei Bogdan

    Caramidaru Andrei Bogdan
    Mr. C Premium Member

    installed everything 2013 RSBR and when i try to play either default or via RScenter,the game starts and i only here the music do not see anything.
    Nothing is clickable as i tried with the mouse to see,esc or enter do not work or arrows, the only whey to exit is alt+f4.
    The game runs under administrator rights so does Rscenter, and WinXp Sp3 compatible(i was thinking it was better) i run win7 64bit
    thank you

    p.s. > yes, very new to this, tried once in the past but now trying again
  2. Nothing is clickable in the game anyway. You navigate the menus with arrows and Enter/Esc.

    Does the original game work fine? Have you changed any settings in RSRBR; resolution, full screen, whatever?
  3. Caramidaru Andrei Bogdan

    Caramidaru Andrei Bogdan
    Mr. C Premium Member

    nop,do not know from where, it does tell me that "this stage needs to adjust resolution" or something like that,where i select the track on the right,but no i did not change anything.
    The game,i did not try, installed it then immediately i put RSBR 2013
  4. I install by:

    Fresh install from richard burns cd to 'C:RBR'
    (I make a folder RBR in C drive and install to that.)

    then offical patches v 1.01 and 1.02

    (at this stage try the game before modding to check for issues)

    then RS2013 Mod (run all as admin)
    then all track packs
    then all car packs
    then the 2013 RS patch

    seems to work ...... I hope you get it going because it is still the best rally game by far, in my humble opinnion.

    • Like Like x 1
  5. Warren Dawes

    Warren Dawes
    Premium Member

    Usually a black screen at that point means that your in-game screen resolution does not match your monitor resolution.

    What is the native resolution of your monitor?
    Have you set up the RBR resolution to be the same? You set the in-game resolution by opening the file Richard Burns Rally.ini with notepad, then set the X-Res and Y-Res to the monitor resolution.

    For example, here is what my RBR.ini says:

    Depth = 32
    ForceFeedback = true
    Fullscreen = true
    MinDepthBits = 24
    MinStencilBits = 8
    ParticleQuality = high
    RenderQuality = high
    RunIntro = false
    RunStartup = false
    Sound = true
    UseCubicEnvironmentMaps = true
    UseEAX = false
    UseSoftwareAudio = false
    UseTripleScreenBuffers = false
    WaitRetrace = true
    XRes = 1920
    YRes =1080

    If it works ok in the base RBR but not in RSRBR, you have to set the resolution and 3D Ratio under RSCenter/File/Settings.

    Hope that helps?

    EDIT: BTW, I always advise people to make sure that their default RBR is working fine before installing RSRBR. Have you read my tutorial (I know it is for RSRBR2012 at this stage, but the basic process is the same for RSRBR2013) ?
    By testing your base RBR fully first, you can then help diagnose if any problems are with your base installation or maybe the RSRBR installation.
    • Like Like x 1
  6. Caramidaru Andrei Bogdan

    Caramidaru Andrei Bogdan
    Mr. C Premium Member

    no my resolutions are dif,as i have 1920/1080 on the monitor but did not find that i can select that on default RBR,will try a completly new install and take it step by step.
    so by modifying the ini i can put any resolution that i want?
    thank you
  7. Warren Dawes

    Warren Dawes
    Premium Member

    Yes, you need to change the resolution to 1920 by 1080 in the Richard Burns Rally.ini file. Those resolutions weren't available when RBR was originally made.
    Same as per my example above.
    XRes = 1920
    YRes =1080
    You can test that it works without re-installing for now. You can change the Richard Burns Rally.ini file, then launch RBR using the default RBR icon from your desktop (not RSCenter). This will launch the default RBR. Try driving the Rally School or a quick Rally. That should tell you if the resolution was the problem.
  8. I had the same problem but it was easy to fix :)

    Open your RBR folder and right-click on the game RichardBurnsRally.exe. Then, in the 'Compatibility' tab select "Disable desktop composition".

    Hopefully that'll fix it for you too
  9. Caramidaru Andrei Bogdan

    Caramidaru Andrei Bogdan
    Mr. C Premium Member

    thank you guys,it worked with "disable desktop composition" and editing the .ini my next problem is that in default game i have no FFB on my g27. it detects it,i can map out buttons and pedals and everything but no FFB, when i press "FFB test" nothing happens...tried to search in .ini but nothing there,My other games work fine,so not from g27.
    thank you