1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
Dismiss Notice
Like RaceDepartment on Facebook.

PC Big stutter but only in races!?

Discussion in 'Assetto Corsa' started by Terry James, Feb 13, 2014.

  1. HI all at RD, I have a problem which I have posted over at AC forums but I wonder if anyone has had anything similar and perhaps could shed some light on my problem listed below:

    Hi, I have a problem and hope I posted this in the right thread. Basically everytime I start a race I get a very noticeable stutter that really spoils my enjoyment with Assetto Corsa. For some unknown reason, I don't get any stutter in practice.

    I have tried the very lowest settings, Tried capping my fps to match my monitor 60hz, Tried with-out my wheel and with a xbox controller, Tried all known suggestions as well, I have even tried disabling my wireless adapter and it seems nothing stops the stuttering. I could cope if it were a minor stutter here and there, But this happens at crucial points, like the hairpin at imola, Right in the braking zone. I am so frustrated as I love this sim, But I am at breaking point. I doubt if AC is to blame but on the other hand my system works flawlessly with other games.

    If there is any suggestions as to my problem please post as I am desperate to get this running without this stuttering. Many thanks in advance, Terry.
    Rig: ROG Maximus V - Gtx 780 - i5 2500k@ 4.3ghz - 8gb Corsair ram - RM850 psu - Asus Xonar s/card - Custom water cooling - 180gb Intel ssd - 64gb Crucial ssd - 500gb spinpoint f3 - Win 7 64 bit

    Input device: Logitech G27

    Assetto settings: 1080p @ 60hz - V-Sync off - Rest to be updated soon.
     
  2. Chris Stacey

    Chris Stacey
    Ted Kravitz Appreciation Society Staff Premium Member

    Are you using a full grid of AI when you race? If so, then that's the reason.
    The CPU processing hasn't been fully optimized for a full grid (or anything over like 15 cars). They're working on this, and we should see frame rates improved over time. You don't see any FPS stuttering in practice mode because there are no AI that your CPU has to process, it's just your car, so it's much easier for it.

    In the mean time, just reduce the number of AI you race against, and your problem will be solved.

    I use 10-12 AI and it runs perfectly :)
     
    • Winner Winner x 1
  3. Ah brilliant Chris and thanks for your prompt reply, I shall def try this and report back. I had noticed that cpu usage was indeed 95%. Fingers crossed!!
     
    • Like Like x 1
  4. Chris Stacey

    Chris Stacey
    Ted Kravitz Appreciation Society Staff Premium Member

    Btw, I'm so jealous of your system, hahah mines a piece of shite compared to that! Haha
     
    • Like Like x 1
  5. I get the stutters with 10 AI at Vallelunga....It only happens in a couple places each lap but it is irritating. Oh well, early access and early days, I'm sure it will only get better.

    i5 2500k @4.3 Two 6950's but crossfire turned off with v-sync turned on.
     
  6. Thanks Chris! I do enjoy having my system as good as it can be and is my pride and joy! The other half don't though :D. It seems that has done the trick and I can race stutter free, So thanks a lot for your advice...Can't wait until we can race AC multiplayer.

    Problem fixed as per Chris's advice for anyone else having this issue!