1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

PC Best Quality / Performance balance graphic settings

Discussion in 'Assetto Corsa' started by hazy, Dec 7, 2013.

  1. This tutorial is meant for single display users with a GFX card = or > GTX 560

    I know there are a few topics on graphic settings but they are meant for high end PC's and most of us haven't got one including me, so I decided to share my settings. I'm running on GTX 560 and I'm getting a constant of 50 FPS on all tracks at every time of day.

    Step 1
    First I would recommend to download the latest GFX drivers, while installing select "Custom (Advanced)", uncheck all the stuff you don't need like 3D Vision, HD Audio and GeForce Exp... Of course leave them checked if you're using a 3D disp or the onboard GFX Audio.

    Make sure to check "Perform a clean installation"

    After installation reboot the PC.

    Step 2
    Right mouse click on desktop, open Nvidia Control Panel and click on "Manage 3D settings" in the 3D Settings section.

    In Global Settings change as fallows -

    : Anisotropic filtering to 16x
    : Antialiasing - FXAA to ON
    : Antialiasing - Transparency to Multisample
    : Maximum pre-rendered frames to 1
    : Mutli-display/mixed-GPU to - Single display performance mode
    : Texture filtering - Negative LOD bias to Clamp
    : Triple buffering to On (even though it's an OpenGL exclusive setting but turn it On just to make sure)
    : Vertical sync to On

    Click Apply

    Step 3
    Step 3 and 4 is meant only for 1920 horizontal resolution at 60hz users, meaning don't do this if you're not playing in FullHD or if your disp isn't a 60Hz one.
    With one exception and that is - if you've got a 120Hz display which supports 100Hz then swap the 50 with a 100.

    Click "Change resolution" in the Display section

    Click "Customize..."

    Click "Create Custom Resolution..."

    Change "Horizontal lines:" to 960 and "Refresh rate (Hz):" to 50

    Click "Test"

    If you will see a box saying "Test successful. Custom resolution 1920 x 960 at 50hz (32-bit) has been applied." then click on Yes
    If the display stays blank for more then 5 sec then press Esc key or wait 15 sec's and skip Step 3.

    It will mean that your display doesn't support 50hz at the given resolution but you can still try 60hz.

    You're probably now asking your self "why 50hz ?" because this game features a constant refresh rate physics engine, just like LFS.
    I'm not sure what that refresh rate is but it surly is a multiplication of 50, most likely it's a 100Hz, like LFS. This means that if you are running the game with Vsync enabled on a non 50, 100 or a 150Hz display then you will encounter stuttering.

    This is the only known way to make sure that no mater what the users graphics limitations are, he will always get the full potential of the physics engine as long as his CPU is capable of producing it.

    The stuttering in AC on this conditions is far less visible then in LFS but I can see it so it's there.

    In conclusion and paradoxically - 50Hz when running Vsync provides a smoother animation then any other non dividable by 50 refresh rate.

    Step 4
    Click "Adjust desktop size and position" in the Display section

    In the "Scaling" tab, select "No scaling:" click the roll out and change to "GPU"

    Check "Override the scaling mode..." and click Apply

    Step 5
    Launch AC and gt to "Options" and "Display"

    Change resolution to 1920 x 960 @ 50Hz at "Single Screen" Rendering Mod

    Check "Fullscreen Rendering"


    Move every slider totally to the left except "Field of View"

    Exit AC

    Step 6 - before editing any files, make backups of them.

    Navigate to your AC installation folder / System / cfg

    Open /Edit - assetto_corsa

    Change :

    RESOLUTION to =256

    Save and close

    Open /Edit - DX11 file

    Change :

    MIP_LOD_BIAS to =-0.25

    Save and close

    Navigate to your Documents folder / Assetto Corsa / cfg

    Open /Edit - video file

    Change :

    Last edited: Dec 24, 2013
    • Beer Beer x 3
  2. panande

    Premium Member

    Uhm my game is black and white? :D the menu is fine but ingame nothing has colour ^^

    Okay I changed colour saturation to 100% again now its fine ^^
    • Haha Haha x 2
  3. Hazy, I have not tried your recomendations ...yet. But THANKS for the info. I too have GTX560 and this should be a great help.
    • Like Like x 1
  4. panande

    Premium Member

    Ok I drove a little bit with the MP4-12C last night. I was a bit sleepy and normally I cant play AC then because somehow the cars would not do what I want them to do.

    On my Mugello lap I was able to do 3 Powerslides through the corners, without being bothered by controlling them :D
    • Like Like x 2
  5. You are welcome, I should mention that my 560 is highly overclocked so if you wont be getting 50 fps at all times then lower MIP_LOD_BIAS to = 0 and SHADOW_MAP_SIZE to = 512 or AASAMPLES to = 4 and leave those other two as they were.

    And that's good right ? ;)
    Last edited: Dec 8, 2013
  6. Maximum pre-rendered frames to 1
    : Mutli-display/mixed-GPU to - Single display performance mode
    : Texture filtering - Negative LOD biad to Clamp

    why do activate/use those things?
  7. Maximum pre-rendered frames to 1 - better response / shorter lag when using Vsync
    Mutli-display/mixed-GPU to - Single display performance mode - optimizes the system for running 1 display and 1 GPU
    Texture filtering - Negative LOD bias to Clamp (it's bias not biad, sorry for that :)) - gives the best image / texture quality when combined with anisotropic .
    • Like Like x 1
  8. I've forgotten about a very important bit - in AC Display setting set the "Framerate limit" to exactly 50.
    Last edited: Dec 9, 2013
  9. why changing the resolution? I don understand the 960 thing. Wouldnt using a different resolution (not native to the monitor) make things blurry?
  10. :whistling:
    Last edited: Dec 11, 2013
  11. cool, i will try it later :)
  12. There's no "[MIRRORS] RESOLUTION" inside assetto_corsa.ini, nor DX11 file inside the cfg folder. This should have changed since this post from 13'. So what can i do?
  13. Would these settings work for my GTX 660
  14. The file is called graphics, now, not dx11. About mirrors, I think you can find inside my documents/assetto/cfg/video
  15. Expanding on the OP....
    One of the things I also found to improve smoothness in Assetto Corsa, is to turn off all the apps under Options/General/UI modules.
    Take it for a spin and then turn on only those you use.
    Since doing this the red graph under render stats always stays flat...no spiking at all.