• You don't get fast in order to take part in club races, you take part in club races to get fast!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. #GiveAwayFriday. Win a copy of F1 2017 - The Game. Click here to join.

Automatic wheel rotation degrees

Discussion in 'Automobilista' started by Michael Bolton, Mar 1, 2016.

  1. Michael Bolton

    Michael Bolton

    Messages:
    8
    Ratings:
    +5
    Does this game support automaticallysetting the rotation degrees?
    If not, should I set the degrees in my thrustmaster drivers and in game each time I change car? What should I set for the trophy trucks? What about the rally cars?
     
  2. Heitor Facuri Cicoti

    Heitor Facuri Cicoti

    Messages:
    291
    Ratings:
    +92
    It does.
     
  3. Tiyr

    Tiyr

    Messages:
    4
    Ratings:
    +0
    I think it should be turned on by default, but in case it's not it's in your settings under Controls > Enable custom steering range. Set it to "No" to have the game automatically set the steering range.
     
  4. Fred Locklear

    Fred Locklear
    Moving bollard Premium

    Messages:
    849
    Ratings:
    +666
    I had it set to No with my Fanatec CSR, but the game was not automatically setting the steering range. I had to go into my wheel and limit the range to the in game rotation to match. I may be missing something, but I will try it again to make sure.
     
  5. Sele1981

    Sele1981

    Messages:
    139
    Ratings:
    +35
    This was on of the problems that kept me away from SCE. Driving the Formula cars out of the pits was like driving a truck. Had to turn the wheel 450 degrees to get out of the pits. I have the Fanatec Base V2. Any tipps what settings I should use for FFB and for steering?
     
  6. Michael Bolton

    Michael Bolton

    Messages:
    8
    Ratings:
    +5
    Yeah this is where I'm confused.. I have disabled custom rotation degrees, and set my thrust master wheel it 900, but it felt very strange, and the wheel in game was not matching my real wheel. What am I missing?
     
  7. Tiyr

    Tiyr

    Messages:
    4
    Ratings:
    +0
    Those of you who can't get it to work, does this feature normally work for you in other games?

    I don't know how Fanatec or TM wheels work, but for Logitech in the wheel settings (in Windows, not the game) there is an option for "Allow game to adjust settings" which needs to be enabled in order for the automatic settings in AMS to work.
     
  8. Andy Jackson

    Andy Jackson
    Unofficial Track Limits Marshall and troll magnet Premium

    Messages:
    6,119
    Ratings:
    +2,809
    There is no such setting in the TM controller software I'm afraid.
     
  9. Michael Bolton

    Michael Bolton

    Messages:
    8
    Ratings:
    +5
    Confirmed. However I rememeber reading somewhere that if I set the wheel rotation to tell lowest part of the slider, it will auto use the game settings. Can anyone confirm this?
     
  10. Thomas Cameron

    Thomas Cameron
    Don't give me your patter Premium

    Messages:
    89
    Ratings:
    +23
    For Fanatec you have to put "sens"to auto or "aut"as it says in the tuning menu.

    Cheers
     
    • Agree Agree x 1
  11. Andrew_WOT

    Andrew_WOT

    Messages:
    162
    Ratings:
    +21
    No such setting in MMos (OSW) but auto rotation works in AC, not in AMS, it only uses full rotation set in driver, regardless of Custom Steering setting.
     
    Last edited: Mar 2, 2016
    • Agree Agree x 1
  12. Fred Locklear

    Fred Locklear
    Moving bollard Premium

    Messages:
    849
    Ratings:
    +666
    I'll give it a shot. I think I have 900 set on the wheel (and not auto). It works fine in AC that way. I'll just set up another preset with it using auto and check it out....that could be the problem.
     
  13. PicoBp

    PicoBp
    #26 | HSRC - Banzaaaiii Touring Car Crew Premium

    Messages:
    726
    Ratings:
    +426
    For TM you should check the Control Panel -> Game Controllers panel if the TM wheel is the first on the list. I experienced that if not, rotation adjustment won't work. Quick workaround is to uninstall the device that is above the wheel from Device Manager and Scan For Hardware Changes. It will put the other device(s) down the list.
     
  14. Sniper

    Sniper
    APIA RACING Premium

    Messages:
    1,263
    Ratings:
    +499
    Also note guys for me the speed sensitivity was set to 50% by default which made the steering feel shite to me. had to turn so far at speed to turn
     
  15. Jim Liak

    Jim Liak

    Messages:
    538
    Ratings:
    +305
    Go to garage when you chosen a car and increase the steering lock. Default is at 16. Try 30.
     
    • Like Like x 1
  16. Fred Locklear

    Fred Locklear
    Moving bollard Premium

    Messages:
    849
    Ratings:
    +666
    Turning the sensitivity setting on my wheel to off worked like a charm. Thanks
     
  17. Michael Bolton

    Michael Bolton

    Messages:
    8
    Ratings:
    +5
    I'm not sure what changed, but automobilista is now perfectly able to change my thrustmaster rotation degrees per car. It even changes the drivers to match! I'm happy I got that sorted. It was a little confusing because the wheel animation can't go past 6 for some reason in the cockpit view, but I meant to disable the wheel anyways
     
  18. Fernando Zart

    Fernando Zart

    Messages:
    422
    Ratings:
    +94
    I have a G25. On profiler, I have the steering wheel marked to use 900 degrees and allow game to make changes. It wasn't working at first, but then I marked AMS.exe to run as admin and everything is fine now.
    I guess that the game must have proper rights to access and "tell" the wheel to set itself to a specific degree - hence the "run as admin" thing.
     
  19. Andrew_WOT

    Andrew_WOT

    Messages:
    162
    Ratings:
    +21
    Does it limit rotation via driver, if so, afraid MMos doesn't work.
     
  20. Kakha Jomardidze

    Kakha Jomardidze

    Messages:
    230
    Ratings:
    +71
    only in AMS (( g27