• "Mwoah" - Kimi Räikkönen
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. Dear Guest. Follow RaceDepartment on Twitter, Facebook, Instagram, Twitch, Steam and YouTube.

Assetto Corsa Launcher freezes after sessions

Discussion in 'Assetto Corsa' started by ltcars, Oct 18, 2017.

Tags:
  1. ltcars

    ltcars

    Messages:
    699
    Ratings:
    +319
    As described in the headline, if I come back from a session (I tried Hotlap and Standard), the Launcher freezes, not showing any signs of overload. I got the issues since I've updated Windows 10 last update (the Fall Creators Update), but I can't figure out any context to that. I did the Steam integrity check but it didn't help. What can I do?
     
  2. RasmusP

    RasmusP
    AC Stuff and G27 help Staff Premium

    Messages:
    2,088
    Ratings:
    +780
    Default Launcher or content manager?
    Please install the demo of content manager and check if that works or not.

    The Launcher is afaik a quite "graphical" thing and my experience is that Windows 10 likes to get hick-ups with these things...
     
    • Like Like x 1
  3. ltcars

    ltcars

    Messages:
    699
    Ratings:
    +319
    Thank you for the response, I have CM installed but I didn't use it for driving, will have a look
     
  4. Andreas Knöpke

    Andreas Knöpke
    Let's drive side by side! Premium

    Messages:
    1,144
    Ratings:
    +366
    Same thing happened to me last night after the big Windows update.
    Can't really tell you what exactly fixed it but I also had to re-do the calibrations of the wheel and pedals and I swapped the windows default screen from 1 to 2 and back in the meantime.
    Afterwards the launcher didn't freeze up anymore.
     
    • Like Like x 1
  5. Andreas Knöpke

    Andreas Knöpke
    Let's drive side by side! Premium

    Messages:
    1,144
    Ratings:
    +366
    I know what causes this.
    Do not uncheck that 2nd option in the GAMES settings thingy of Windows 10.
     
    • Like Like x 1
  6. Martin Fiala

    Martin Fiala
    Premium

    Messages:
    1,700
    Ratings:
    +1,848
    @Andreas Knöpke Could you perhaps elaborate a bit more on what "GAMES settings thingy" are you talking about? Cheers.

    Edit: Nevermind, I guess you're talking about the Gaming settings options. I have the second option (Show game bar in games Microsoft has verified) checked and the launcher still stops responding to upon leaving the track :(
     
    Last edited: Oct 21, 2017
    • Wow Wow x 1
  7. Nimix

    Nimix

    Messages:
    6
    Ratings:
    +0
    Same issue here, the launcher doesn't freeze per say, but the clicks go through it (they will register on the window opened behind the launcher and tab out of it). If I right click/exit program in the task bar, the "do you want to exit" dialog pops into the launcher, but all my clicks go through it to whatever is behind it x_x
     
  8. Martin Fiala

    Martin Fiala
    Premium

    Messages:
    1,700
    Ratings:
    +1,848
    It seems to me there have been some changes with the way fullscreen programs behave, compared to how it used to be. It now regularly happens to me that if I move my mouse to the left side of the screen while in a fullscreen app/game, my dock (which is set to "always on top") pops up, which it never did before.

    So with the AC launcher, it kinda seems as if it appears it is on top of all the other apps, but in reality, when I try to click on it, I'm clicking on whatever's "below it", be it a browser window or a desktop. So it's not really frozen, there just seems to be no way to click on it.

    (And no, before anyone asks - my dock isn't the issue, I've tried. I've tried most of what I could think of or what people have suggested on the internet, no dice.)
     
  9. Nimix

    Nimix

    Messages:
    6
    Ratings:
    +0
    Yep exact same issue as you Martin. This is really weird :<
     
  10. The Zman

    The Zman

    Messages:
    9
    Ratings:
    +1
    I rolled back the Windows 10 update to the previous one and everything in Assetto Corsa was back to normal.
     
  11. guidofoc

    guidofoc

    Messages:
    186
    Ratings:
    +103
    One thing that happens to me recently is that I need to do alt+enter each time when in drive mode, otherwise the game is not really in full screen mode and has reduced fps.
     
  12. Martin Fiala

    Martin Fiala
    Premium

    Messages:
    1,700
    Ratings:
    +1,848
    BTW does anyone else suffering from these issues have dual screen (multi screen?) setup? It's kinda starting to seem like it's related to dual screen setups and the problem supposedly goes away if you just use single screen.

    I've tried to run the game with a single screen setup (as opposed to my regular dual screen - game only on one monitor) and it does indeed fix this issue for me.
     
    Last edited: Oct 28, 2017
  13. Nimix

    Nimix

    Messages:
    6
    Ratings:
    +0
    Yeah I'm using dual screen, good to know thanks!
     
  14. ltcars

    ltcars

    Messages:
    699
    Ratings:
    +319
    I use single screen, but have a smaller screen as well, which I don't use for AC
     
  15. SrRixdmarc

    SrRixdmarc

    Messages:
    19
    Ratings:
    +3
    Just a hour ago I formatted my PC to W10 Build 1703 (Not FALL Creators Update) and the launcher seems to be fine, but I have another problem, in this vesion and the updated version of W10 FFB does rare moves. When I keep the steeing (T500RS) in the middle, it starts vibrating (it starts when the car passes 3km/h) rare rare... Anyway, i'm gonna create a post asking for help. But the launcher issue is because of the W10 Fall Update.
    Cheers.
     
  16. Martin Fiala

    Martin Fiala
    Premium

    Messages:
    1,700
    Ratings:
    +1,848
    BTW, alternative workaround suggested on AC forums that works for me - switch the launcher to windowed mode by pressing F11. Then it responds to mouse even after leaving the race.
     
    Last edited: Oct 29, 2017
  17. Nimix

    Nimix

    Messages:
    6
    Ratings:
    +0
    Thanks a lot!
     
  18. ltcars

    ltcars

    Messages:
    699
    Ratings:
    +319
    I tried but it didn't work for me
     
  19. Martin Fiala

    Martin Fiala
    Premium

    Messages:
    1,700
    Ratings:
    +1,848
    I guess there's several issues with similar symptoms, judging from what I see people mention.
     
  20. ltcars

    ltcars

    Messages:
    699
    Ratings:
    +319
    Now worked, tried it after freezing, you have to press F11 when first launching the Launcher;)