• Home of the RD Le Mans Series by Vesaro
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Any fixes for connection problems around?

Discussion in 'F1 2012 - The Game' started by ptroinks, Jul 16, 2013.

  1. I just got a friend of mine to buy F1 2012 so we could race co-op together, but now we're both unable to create sessions, or, if one of us manages to create a session, the other player can't connect. We've both made sure that exceptions are made in the Windows firewall, and we're pretty pissed that we're still unable to play this game together. Does anyone have any tips on how we can fix this problem?
  2. mystaaRS

    If you get a Quali Place, you can get a Race Pace

    I also couldn't connect for some reason, hopefully it's not because CM shut the online down.
  3. They shut it down?
  4. Graham Laing

    Graham Laing
    ...... mostly harmless Staff

    There is no way it would be shut down, apart from a temporary technical problem
  5. So this is another bug, then! Is there nothing else I can try to make this work for us?
  6. Graham Laing

    Graham Laing
    ...... mostly harmless Staff

    For Steam you need these ports open :-


    Plus TCP port 443 for F1 2012

    Then go to portforward.com and look up your router model number here :-


    Once you have selected your router, there will be a list of games and applications. The Codemaster F1 series is probably not listed but Steam is listed.

    If you click to the Steam Client (perhaps Steam Server too), there will be a step through guide in how to forward the ports on YOUR router for Steam. I don't know if their list of ports match the ones in the steam link above, but they should do.

    Once you get the idea on how to forward ports, you can also add that TCP port 443 I mentioned above for F1 2012.

    After you have done this, if it still doesn't work, then you might want to try and disable the Windows Firewall just to see if this fixes it. If it does fix it, then the firewall need adjusting (ports opened), or just disabled when playing the game