1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

an unhandled exception error....

Discussion in 'Bob's Track Builder' started by Alex Kyriak, Nov 2, 2009.

  1. :sick: Got an unhandled exception error on exporting to Rfactor..... can anyone help or tell me what this means? I really really REALLY want to be able to rescue this....

    edit: I've removed all object, Sobjects, and walls, and still get this error.

    See the end of this message for details on invoking
    just-in-time (JIT) debugging instead of this dialog box.
    ************** Exception Text **************
    Error in the application.
    -2005530516 (D3DERR_INVALIDCALL)
    at Microsoft.DirectX.Direct3D.BaseMesh.Clone(MeshFlags options, VertexElement[] declaration, Device device)
    at BobsBits.rFactor_GMT.PopulateFromTrackOrWallMesh(Mesh Mesh, Vector3 Offset, SurfaceMaterials loSurfaceMaterials, String lsName, XPacks l_XPacks, Boolean lbReceiveLighting, Single LODIn, Single LODOut, Boolean IsTreeWall)
    at BobsBits.ISIEngine.rFactor_Venue.CreateSurfaceObject(Surface Surface, String TrackPiece, String Extension, Int32& SurfaceCount, Boolean Driveable, Boolean Collideable, Boolean Moveable, Boolean Render, Boolean ShadowReceiver, Boolean ReceiveLighting, Shadows Shadow, Boolean ShadowOnMoveables, ShadowCasts ShadowCast, ShadowQuality ShadowQuality, Single LODIn, Single LODOut, VisibilityGroup rFactorVisGroup, Boolean IsTreeWall)
    at BobsBits.ISIEngine.rFactor_Venue.CreateSurfacesObjects(Surfaces Surfaces, String TrackPiece, String Extension, Boolean Driveable, Boolean Collisions, Boolean Moveable, Boolean Renderable, Boolean ShadowReceiver, Boolean ReceiveLighting, Shadows Shadow, Boolean ShadowOnMoveable, ShadowCasts ShadowCast, ShadowQuality ShadowQuality, Single LODIn, Single LODOut, VisibilityGroup rFactorVisGroup, Boolean IsTreeWall)
    at BobsBits.ISIEngine.rFactor_Venue.AddTrack(Int32 TrackId)
    at BobsBits.ISIEngine.rFactor_Venue.AddTracks()
    at BobsBits.ISIEngine.rFactor_Venue.CreateAll(Vector3 Offset, String VenueFolder, String TrackFolder)
    at BobsBits.Venue.ExportForrFactor(String ExePath, String VenueFolder, String TrackFolder, String VenueName, String TrackName, Boolean OverwriteTDF, Boolean OverwriteGDB, Boolean OverwriteSCN, Boolean OverwriteAIW, Boolean OverwriteCAM)
    at BobsTrackBuilder.frmExport.butrFactorExport_Click(Object sender, EventArgs e)
    at System.Windows.Forms.Control.OnClick(EventArgs e)
    at System.Windows.Forms.Button.OnClick(EventArgs e)
    at System.Windows.Forms.Button.OnMouseUp(MouseEventArgs mevent)
    at System.Windows.Forms.Control.WmMouseUp(Message& m, MouseButtons button, Int32 clicks)
    at System.Windows.Forms.Control.WndProc(Message& m)
    at System.Windows.Forms.ButtonBase.WndProc(Message& m)
    at System.Windows.Forms.Button.WndProc(Message& m)
    at System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m)
    at System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
    at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)
  2. Have you tried going back to one of the backups in 'Temporary Files' folder?
  3. I think I found the venue.bin trick on this site, but I'm not sure if I'm doing it right. I renamed the one with the same filesize, but produces the same error.

    I 'Save As' relatively regularly, but this export error went unnoticed for the last four saves... in which time some fairly big changes happened.
  4. The one with the same filesize probably has the error, you want an earlier one [smaller filesize]. Sort the files by date in windows explorer and go back that way.

    There should be many many to choose from.
  5. .... thanks for the advice chub. The problem only occurs when I do an export, so if I don't test export every 10 minutes or so, I'll never know if a problem has crept in there. I had been working away happily, did my multiple saves, but as this problem must have occured a while back, and I haven't exported for a while, I've lost a lot of work. Am really annoyed - I have pinpopinted at which point the problem occured, but unfortunately it's too far back. :(
  6. Before you accept defeat, clear the AIW info and try it again.

    If that doesn't fix it, look in the output directory and see the last object that was created. Usually that will tell you what object is causing the issue. If you open the .gmt file in notepad and scroll down towards the bottom, you will see what texture it uses, which will give you an idea what object it is. Remove all those Objects that use that texture and try to export again. (*note, I'm not saying its the texture at fault, the texture is just a reference to what object your looking for.)

    A good idea is the save the project as copy and work on the copy when troubleshooting. That way when you find the problem you can go back to the original and fix it, without loosing much work.
  7. Thanks Mianiak - gave it a try but still nothing.

    Check this out though - see attached - when I move a node to a certain region, it will display error on export. when I move the node back, export works fine. Move the node to that position, and error, move back, exports fine, repeatable over and over. Wierd..... Anyone seen anything like this or know what this could be?

    EDIT: it may be connected to track length. Have tried this with other nodes and it crashes above a certain track length, and not below, irrespective of node region.

    Attached Files:

  8. The problem then goes away again when I increase track panel length from 3 to 5, until the track length exceeds a certain higher length. So at 3 panel length, 24km errors on export. With 5 panel length, exports fine for 24km. 5 panel length errors on export at 45km, but fine up to then. So it's something to do with length? Track panels? Feel like I'm getting somewhere, but still can't solve it.
  9. EDIT: by going from 3 panel length to 5 panel length on the track, the original problem at the top of this thread has been solved, simple as that - it now seems to work fine again. Don't know how or why...