1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
Dismiss Notice
Like RaceDepartment on Facebook.

11 New Tracks Pack

Discussion in 'Racer Tracks' started by QuadCoreMax, Jan 30, 2013.

  1. Hey all,

    I'm finally releasing all the tracks I've been working on those years...:)

    Take a massive breath & drive top quality tracks, especially designed & optimized for Racer 0.8.39.
    A big thanks to everyone making this possible !

    Enjoy !

    [​IMG]

    [​IMG]

    [​IMG]

    [​IMG]

    [​IMG]

    [​IMG]

    [​IMG]

    [​IMG]

    [​IMG]

    [​IMG]

    ********************************************************************
    Please consider donating as it take lots of time to develop
    ********************************************************************​


    [​IMG]

    11 New Tracks Pack Slideshow
    Download Tracks
     
    Last edited: Sep 17, 2015
    • Like Like x 8
  2. Thanks Quadcore, new tracks are always appreciated. :)

    Alex Forbin
     
  3. Mmmm very nice compilation of old and new tracks!! Lot's of fun here, thanks QuadCore!
     
  4. Alexander Knoll

    Alexander Knoll
    NEVER GIVE UP!!

    Awersome!! THX QCM
     
  5. Can you supply the track lists.
     
  6. Thanks guys, I appreciate. :)
    The new released track list :

    Atlantlis City
    Boujma
    Gypkin
    Mystical Circles City
    Nishu
    Orska
    Pajani
    Taupoulos
    Tyshen
    UV City
    Yumba

    Mystical Circles & UV City don't have any outer terrains for now.
     
    • Like Like x 1
  7. Wow! Thank you man!
     
  8. So, what's the best track in your opinion ?
    What's the stuff that you feel needs more attention ?

    Feel free to report/feedback anything that goes thru your mind !

    For those, who want to make their own cars AI for the tracks, here's the best way :

    After starting the free drive, press CTRL + F6.
    Drive nicely until the record is finished.
    Before, you press CTRL F7 to save the AI, open console & press 'ai smooth 10'.
    Done !

    Just a note, UV City was one of the 1st test of having some smoothed curved roads & buildings. Still there was, as I looked to my code yesterday a wrong setup projection method (it was in world instead of local), so in next updates, you will see everything correctly set & smoothed out (2m usually) !

    I hope you get what I mean !
     
  9. Okay, so I've downloaded a few of this tracks: Atlantis, Boujma, Gypkin, Mystical Circles and Orska. I can say about them, that they are really good ;) Only thing that disturbs in comfort driving is that they are (don't knowhow to call it) too bright, so the visibility isn't very god, and there's no real night. I talk about really dark night.

    Some screens from these tracks, I hope you will see what i mean.
    [​IMG][​IMG][​IMG][​IMG][​IMG][​IMG][​IMG][​IMG]
     
  10. Correct, I have messed up a little the special.ini + all TOD curves could be looking better.
    What are the best ways of having a nice TOD when you fast_time 200 for example in the console & drive at night ?
     
  11. Great tracks for sure, but i still have a problem with "Freehand", it closes 1 second after start it... Thanks!
     
  12. Pradzio, maybe a "cloud-time verification" script which verifies the time & sets the clouds amount to 0 between 18H/6pm - 6h/6am to get a realistic black night. The third image illustrates the problem.

    tormento, what does the qlog.txt saying ?
    Is anyone else having problems ?

    Maybe it's the textures size, but strange because Racer default texture size is set to 2048x2048 pixels which I've use to pack all buildings.
     
  13. Eh, my knowledge about TOD and other stuff connected with making tracks for Racer is very poor, but I can show you something.

    For me, this night looks quite good.

    [​IMG][​IMG]

    But really perfect night is when, when you can't see anything without using lights ;)
     
  14. All your other tracks of this pack work great!! But Freehand closes after 1 second. Here it's the QLOG, thanks!!

    Code:
    Sat Feb 02 22:18:38 (INFO ): [racer] --- application start ---
    Sat Feb 02 22:18:38 (INFO ): [racer] Racer version: 0.9.0 RC4 (Aug  9 2012/14:30:13) - customer: Internet [main.cpp:186 / main]
    Sat Feb 02 22:18:39 (ERR  ): [racer] wglGetProcAddress(glProgramVertexLimitNV) failed [gllextmgr.cpp:138 / check_wglGetProcAddress]
    Sat Feb 02 22:18:39 (INFO ): [racer] render engine using Cg (4.20) [dgpushader.cpp:47 / DGPUShaderManager::DGPUShaderManager]
    Sat Feb 02 22:18:39 (INFO ): [racer] DGPUShaderManager::Init() Geometry shading is not supported on this card (ATI?). [dgpushader.cpp:139 / DGPUShaderManager::Init]
    Sat Feb 02 22:18:39 (WARN ): [racer] DGPUShader:Load(data/renderer/fullscreen_shaders_hdr/bloom_shadows_f.cg): The profile is not supported. [qerror.cpp:41 / QShowCGErrors]
    Sat Feb 02 22:18:39 (INFO ): [racer] WorldRenderer: you have an ATI graphics card (ATI Technologies Inc.). Working around some long-term bugs. [renderer.cpp:543 / WorldRenderer::GetProperties]
    Sat Feb 02 22:18:39 (WARN ): [racer] envmap.generate_mipmaps is 1 but ATI drivers don't support texCUBElod for mipmapped envmaps in Cg [rmanager.cpp:1011 / RManager::Create]
    Sat Feb 02 22:18:39 (INFO ): [racer] DFrameLock::SetVSync: set vsync to 0 (verify that it now is 1) [dframelock.cpp:160 / DFrameLock::SetVSync]
    Sat Feb 02 22:18:39 (INFO ): [racer] Physics engine: NEWTON v2.34, architecture 0 [rmanager.cpp:1417 / RManager::Create]
    Sat Feb 02 22:18:39 (INFO ): [racer] FMOD: software format default is rate 48000, fmt 2, outChannels 2, inChannels 6, resampler 1, bits 16 [qsample.cpp:1395 / QSampleSetup]
    Sat Feb 02 22:18:39 (INFO ): [racer] FMOD: attempted software format is rate 44100, fmt 2, outChannels 2, inChannels 6, resampler 3, bits 16 [qsample.cpp:1411 / QSampleSetup]
    Sat Feb 02 22:18:39 (INFO ): [racer] FMOD: modified software format is rate 44100, fmt 2, outChannels 2, inChannels 6, resampler 3, bits 16 [qsample.cpp:1415 / QSampleSetup]
    Sat Feb 02 22:18:39 (INFO ): [racer] Controls: main control file is 'profile1.ini' [rcontrolengine.cpp:814 / RControllerEngine::OpenConfig]
    Sat Feb 02 22:18:39 (INFO ): [racer] Safety changed to: SAFE [rcontrolengine.cpp:460 / RControllerEngine::StepInput]
    Sat Feb 02 22:18:43 (INFO ): [racer] Loading track 'Freehand' [rtrack.cpp:1253 / RTrack::Load]
    Sat Feb 02 22:18:43 (WARN ): [racer] Splines lines.paint_end (1) >= lines.count (0); capping to -1 [rspline.cpp:179 / RSplineRep::Load]
    Sat Feb 02 22:18:48 (WARN ): [racer] No splines found; minimap is disabled. [rminimap.cpp:177 / RMiniMap::PaintRoad]
    Sat Feb 02 22:18:48 (INFO ): [racer] QNClient:Connect() attempt to localhost:25000 (RNetworkManager) [client.cpp:212 / QNClient::Connect]
    Sat Feb 02 22:18:48 (INFO ): [racer] QNClient: connected to server (our clientID=71, client name 'RNetworkManager') [client.cpp:567 / QNClient::Poll]
    Sat Feb 02 22:18:48 (WARN ): [racer] No AI found for track Freehand, car renault_clio_i (also no ai/default.ini) [railines.cpp:122 / RAILines::Load]
    Sat Feb 02 22:18:48 (INFO ): [racer] Loading car 'renault_clio_i' [rcar.cpp:922 / RCar::Load]
    Sat Feb 02 22:18:48 (WARN ): [racer] d3LoadTextureMap(); can't load 'light.tga'; creating red/blue stub image [dflat.cpp:301 / d3LoadTextureMap]
    Sat Feb 02 22:18:48 (WARN ): [racer] DTextureManager:MakeObject(light.tga) couldn't find image [dtexturemgr.cpp:57 / DTextureManager::MakeObject]
    Sat Feb 02 22:18:48 (WARN ): [racer] No AI found for track Freehand, car renault_clio_i (also no ai/default.ini) [railines.cpp:122 / RAILines::Load]
    Sat Feb 02 22:18:48 (WARN ): [racer] RCamera: camera0's offset and offset_to are too close - move them apart [rcamera.cpp:312 / RCamera::Load]
    Sat Feb 02 22:18:48 (WARN ): [racer] RCamera: camera3's offset and offset_to are too close - move them apart [rcamera.cpp:312 / RCamera::Load]
    Sat Feb 02 22:18:48 (WARN ): [racer] RCamera: camera9's offset and offset_to are too close - move them apart [rcamera.cpp:312 / RCamera::Load]
    Sat Feb 02 22:18:49 (INFO ): [racer] Loading car 'renault_clio_i' [rcar.cpp:922 / RCar::Load]
    Sat Feb 02 22:18:49 (WARN ): [racer] RCamera: camera0's offset and offset_to are too close - move them apart [rcamera.cpp:312 / RCamera::Load]
    Sat Feb 02 22:18:49 (WARN ): [racer] RCamera: camera3's offset and offset_to are too close - move them apart [rcamera.cpp:312 / RCamera::Load]
    Sat Feb 02 22:18:49 (WARN ): [racer] RCamera: camera9's offset and offset_to are too close - move them apart [rcamera.cpp:312 / RCamera::Load]
    Sat Feb 02 22:18:49 (WARN ): [racer] No AI found for track Freehand, car alfa_8c (also no ai/default.ini) [railines.cpp:122 / RAILines::Load]
    Sat Feb 02 22:18:49 (INFO ): [racer] Loading car 'alfa_8c' [rcar.cpp:922 / RCar::Load]
    Sat Feb 02 22:18:49 (WARN ): [racer] Can't find car.ini for 'alfa_8c' (file 'data/cars/alfa_8c/car.ini' not found) [rcar.cpp:946 / RCar::Load]
    Sat Feb 02 22:18:49 (WARN ): [racer] Can't load car 'alfa_8c' [rmessage.cpp:728 / RMessage::InNewCar]
    Sat Feb 02 22:18:49 (WARN ): [racer] No AI found for track Freehand, car mini (also no ai/default.ini) [railines.cpp:122 / RAILines::Load]
    Sat Feb 02 22:18:49 (INFO ): [racer] Loading car 'mini' [rcar.cpp:922 / RCar::Load]
    Sat Feb 02 22:18:49 (WARN ): [racer] Can't find car.ini for 'mini' (file 'data/cars/mini/car.ini' not found) [rcar.cpp:946 / RCar::Load]
    Sat Feb 02 22:18:49 (WARN ): [racer] Can't load car 'mini' [rmessage.cpp:728 / RMessage::InNewCar]
    Sat Feb 02 22:18:49 (WARN ): [racer] No AI found for track Freehand, car alfa_8c (also no ai/default.ini) [railines.cpp:122 / RAILines::Load]
    Sat Feb 02 22:18:49 (INFO ): [racer] Loading car 'alfa_8c' [rcar.cpp:922 / RCar::Load]
    Sat Feb 02 22:18:49 (WARN ): [racer] Can't find car.ini for 'alfa_8c' (file 'data/cars/alfa_8c/car.ini' not found) [rcar.cpp:946 / RCar::Load]
    Sat Feb 02 22:18:49 (WARN ): [racer] Can't load car 'alfa_8c' [rmessage.cpp:728 / RMessage::InNewCar]
    Sat Feb 02 22:18:49 (WARN ): [racer] No AI found for track Freehand, car mini (also no ai/default.ini) [railines.cpp:122 / RAILines::Load]
    Sat Feb 02 22:18:49 (INFO ): [racer] Loading car 'mini' [rcar.cpp:922 / RCar::Load]
    Sat Feb 02 22:18:49 (WARN ): [racer] Can't find car.ini for 'mini' (file 'data/cars/mini/car.ini' not found) [rcar.cpp:946 / RCar::Load]
    Sat Feb 02 22:18:49 (WARN ): [racer] Can't load car 'mini' [rmessage.cpp:728 / RMessage::InNewCar]
    Sat Feb 02 22:18:52 (INFO ): [racer] WorldRenderer: you have an ATI graphics card (ATI Technologies Inc.). Working around some long-term bugs. [renderer.cpp:543 / WorldRenderer::GetProperties]
    Sat Feb 02 22:18:52 (WARN ): [racer] envmap.generate_mipmaps is 1 but ATI drivers don't support texCUBElod for mipmapped envmaps in Cg [rmanager.cpp:1011 / RManager::Create]
    Sat Feb 02 22:18:52 (INFO ): [racer] DFrameLock::SetVSync: set vsync to 0 (verify that it now is 1) [dframelock.cpp:160 / DFrameLock::SetVSync]
    Sat Feb 02 22:18:52 (INFO ): [racer] Physics engine: NEWTON v2.34, architecture 0 [rmanager.cpp:1417 / RManager::Create]
    Sat Feb 02 22:18:52 (INFO ): [racer] Controls: main control file is 'profile1.ini' [rcontrolengine.cpp:814 / RControllerEngine::OpenConfig]
    Sat Feb 02 22:18:52 (INFO ): [racer] Safety changed to: SAFE [rcontrolengine.cpp:460 / RControllerEngine::StepInput]
     
  15. Those 2 seems to be the origin...
    If you set in your racer.ini file, envmap > generate_mipmaps=0 & damage > vertex_damage=0, what happens ?
    It happens that all tracks crash here, when I set those 2 variables to 1 with 0.8.39.
     
  16. Generate_mipmaps set to 0 with the same result, vertex_damage value 0 too. Very strange because i can run all the other tracks of your list even with the variable=1
     
  17. Sorry Tormento, I don't know what's the cause, almost sure it's the (err) message. Usually Racer can work even when there's WARN or INFO messages...but not the ERR

    Someone experienced knows something ?

    @All

    Anyone found serious other qlog errors ? I was thinking about Boomer who usely verifies everything, but I guess there's nothing to fix for versions under 0.8.40..

    & Sorry guys, I didn't check any track with latest versions, as I was kind of disappointed with latest versions, but I can understand how difficult for Ruud it must be to upgrade & implement new features, so I stay patient & confident.
     
  18. Don't mind :) Will try another things to see if it works, thanks again!!
     
  19. The only one of the ii I've tried is the Atlantis track which has a problem with the trees floating above ground level.No Qlog errors but those trees need to be planted. Tested on Ver 090 rc3. When I have time I'll try the rest.

    There is an error in the gfx section of the special.ini file, I'll let QCM find it. Hint - it's 0930 am.
     
  20. Atlantlis Updated....
    Link

    Updates :

    - track.ini km update
    - new loading + preview wide-screen images
    - new tree texture
    - flat outter terrain included
    - sky fixed where RGB channels have now their colors - Night working !!
    - minor shader updates for the road & water with some bump normal maps

    Known Issues :

    - you can fall into the 3D scene when driving far outside the city
    - some vertices are not merged together when driving outside - terrain >< curbs

    Missing Features :

    - a lot ! :)

    Just to recall everyone, it's the 1st city ever made for Racer by myself with all building detailed...approx 200K the whole scene. All buildings textures are also made by me, there were all extracted from StreetView & edited later in PS.

    Unfortunately, the road wasn't subdivided further because of the buildings topology. Maybe at some point in time !
     
    • Like Like x 1