• "Bite off more than you can chew and then chew like hell." - Peter Brock
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

1.2.1.9 Patch (Steam)

Discussion in 'RACE 07 - Official WTCC Game' started by Günthar Rowe, Jun 22, 2011.

  1. Günthar Rowe

    Günthar Rowe

    Messages:
    3,796
    Ratings:
    +29
    Updates to Race 07 have been released. The updates will be applied automatically when your Steam client is restarted. This patch will bring your game to version 1.2.1.9

    It includes the following changes:

    • Race'07 and dedicated server are now "hillclimb-enabled" to support the upcoming Retro Expansion
    • New smoke effects
    • New corner markers that are now valid for any type of car on a given track
    • Fix for a missing button in championship mode that did not allow the user to go back
    • Fix for 64bits operating systems where the game could suddenly run out of memory and crash
     
  2. Mike Roe

    Mike Roe

    Messages:
    82
    Ratings:
    +18
    thought the winning FRR skins might have been in there too, my game wont start atm so cant check.
     
  3. Günthar Rowe

    Günthar Rowe

    Messages:
    3,796
    Ratings:
    +29
    This is a game patch, not an content update.

    What O/S are you running Mike?
     
  4. Jempy

    Jempy
    Premium

    Messages:
    732
    Ratings:
    +191
    Patch installed for me and no problem except ......XD Plugin as usual :tongue:
     
  5. Ross Garland

    Ross Garland
    A legend in my own mind... Premium

    Messages:
    4,603
    Ratings:
    +1,428
    New smoke... what an odd thing to patch after all this time. Anyway, nice to see the hillclimb support added. It must mean the Retro expansion is imminent!
     
  6. Zeynel Babacan

    Zeynel Babacan

    Messages:
    738
    Ratings:
    +27
    @ Mike

    I get the same problem.
    But i start only Race07 and it worked.
    Try after Race On and it will work again.
     
  7. Andreas Lündin

    Andreas Lündin

    Messages:
    87
    Ratings:
    +11
    Hmmm does it fix the problem with some tracks, like Gothenburg that seems to have some sort of memoryleak....
     
  8. Ross Garland

    Ross Garland
    A legend in my own mind... Premium

    Messages:
    4,603
    Ratings:
    +1,428
    If it isn't in the patch notes, then I would suggest that it doesn't.
     
  9. Günthar Rowe

    Günthar Rowe

    Messages:
    3,796
    Ratings:
    +29
    basically, the main reason for the patch is to get the platform up and running before the Retro Pack release. Bugs and things that are show stoppers can be quickly corrected and not be confused with anything that might be introduced by the new content that comes with Retro Pack. It's a easier way to roll out things IMHO... Looking forward to some Hill action for sure!!
     
  10. Günthar Rowe

    Günthar Rowe

    Messages:
    3,796
    Ratings:
    +29
    with every update, you need to start the game via Race 07 first (just once) and then all other add-on content launchers will function correctly.
     
  11. Mike Roe

    Mike Roe

    Messages:
    82
    Ratings:
    +18
    it was just steam being a biatch, Verified game cache and it updated again and was then fine.
     
  12. p00se2

    p00se2

    Messages:
    53
    Ratings:
    +0
    is there any way to get the old corner markers back ? i hate those arrows :/
     
  13. Kennett Ylitalo

    Kennett Ylitalo

    Messages:
    4,695
    Ratings:
    +3,936
    New smoke effect is great, tried it with F1 and now you can see smoke coming from the frontwheels when locked under braking.. Before only others saw it, much better this way.
     
  14. Craig Stevenson

    Craig Stevenson

    Messages:
    918
    Ratings:
    +141
    I still can't start the game after update and expansion installation, it shows briefly in Friends as "In-Game" but it doesn't actually start the game, I have verified the cache for Race 07 and all expansions listed in Steam Library, I have defraged the same, I have reset the display settings, I have tried running the game from each expansion listed in the Steam Library and through Icons on Desktop and Start Menu, I have restarted Steam and rebooted the computer and it still won't start, really not happy!
     
  15. Jim Cole

    Jim Cole
    Premium

    Messages:
    1,703
    Ratings:
    +122
    try and delete the 2 blob files and then start Race 07 icon.
     
  16. Craig Stevenson

    Craig Stevenson

    Messages:
    918
    Ratings:
    +141
    It seems it may be MotecAdd, I removed the Retro expansion and still wouldn't start then someone on RaceRoom Forum mention removing the MotecAdd .dll (d3d9.dll), Race07 has now started ok so just re-downloading the Retro pack............
     
  17. Craig Stevenson

    Craig Stevenson

    Messages:
    918
    Ratings:
    +141
    That seems to have worked, game now starts as normal, so Patrick if you're about you have some work to do mate :)
     
  18. Aleksey Bogatyrev

    Aleksey Bogatyrev

    Messages:
    149
    Ratings:
    +0
    looks like MotecAdd doesn't work after this update, are they gonna release a patch?
     
  19. Jim Cole

    Jim Cole
    Premium

    Messages:
    1,703
    Ratings:
    +122
    A new dll has been released for XD so I am sure that AD will have a patch some time soon. Be patient folks :)

    On another note, I just tried out running the race room F1 cars since the patch and I can now do something I have never done before. I am able to flip the car coming out of the garage and have never seen that happen before.
     
  20. Dennis Phelan

    Dennis Phelan
    more about staying on track. Premium

    Messages:
    8,281
    Ratings:
    +2,717
    Leadfoot!