1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

0.8.29 Clutch problems

Discussion in 'Racer Problems & Fixes' started by francomk, Jan 2, 2011.

  1. Is anybody having problems when running car with autoclutch off (both in Car.ini and racer.ini)? I must still run all my content on 0.8.28, because car won´t move in 0.8.29 (same happened with 0.8.29a and 0.8.29b exe patches from Ruud), just stands still and engine can be revved ot the max even with gears shifted in :( Even when I´m not holding the clutch (clutch RAW control readout = 0%), ingame readout shows "clutch=100%" Everything´s right here, controller file, racer.ini, car.ini... So I don´t know, where´s the problem. When I have autoclutch turned on, cars are running fine (with autoclutch functions).
    It´s a bit annoying for me...

    P.S.: Happens to all cars with autoclutch turned off, not only my T613!

    Clutch released...

    ... but still at 100% ( 2nd line in readout)
  2. Alexander Knoll

    Alexander Knoll

    Hi dude,
    for me it works fine...no problems with 029a/b or 029.....

    screenshot009.jpg screenshot010.jpg

    ...pics are with the 029....autoclutch rpm =2500.....
  3. Same here, seems to happen at random. Was driving around carlswood, managed one lap, then the bug appeared and no more driving for me.

    I think I nailed it down, atleast concerning my System.

    Using the G27 Paddle Shifters (after autodetecting the controller) for two times (no matter if it is upshift or downshift) will induce that Bug. The first down/ upshift will work, the second will have the mentioned bug as a result. Did not have the problem when using the H-Shifter.

    Tested this on the Tatra
  4. Alexander Knoll

    Alexander Knoll

    Ok, i does a 5 Lap race, and all works fine!
    I'm using my DFP, autodetect, paddle shifters...

    Are you sure you not burnd the clutch^^?
  5. Aside from being sarcastic, no. If the clutch would break after one up- or downshift then missing a gear would have to have an apocalypse as a result.

    It's simply that, another bug in racer. Nothing new, really ;)

    Doesn't only happen with the Tatra, as francomk noticed.
  6. Alexander Knoll

    Alexander Knoll

    hmm...not sure if it is a generally bug....because i have no problems...the tatra (and all cars/tracks too...) works wonderfull! Thanks Cosmo°, the ai too....

    The burnd clutch was a try of a joke, sry....
  7. Ruud

    RACER Developer

    You mean you have this when using a clutch pedal yourself? If you don't do the clutch yourself, it works fine?
  8. I Have Logitech DFP (no clutch pedal) and using left paddle as clutch. That means I shift mostly without using clutch. I have this problem all the time, when autoclutch=0 (both in racer.ini and car.ini)
  9. Alexander Knoll

    Alexander Knoll

    try this:

    DivShare File - logitech_driving_force_pro_usb.7z
  10. Still the same problem, Alex... :frown:
  11. Alexander Knoll

    Alexander Knoll

    oh...then i have no idea what it should be.....sry...
  12. I don't have a solution yet either, but I can at least reproduce the problem which Ruud should also be able to.

    My default controller file (G27) has free shifting enabled and the fallback file doesn't. On vehicles that use autoclutch, shifting with the paddles works as intended and manual transmission vehicles work fine with the h-pattern input as well. It also does so when direct shifting is used together with autoclutch=1. However, when I use the paddles on a vehicle without autoclutch, Racer locks the clutch and driving is impossible. Reloading the controller file doesn't unlock it either, only restarting Racer gets it back to normal.

    I also noticed the same thing when switching back and forth between AI mode and driving myself.
  13. I've noticed this now.

    I was testing the Lambo in manual/stalling and setting off and all that stuff.

    Turned off auto-clutch in racer.ini, and that is when the problems started.

    Lots of just sat there with the clutch=100% in debug readout screen not going anywhere :D

  14. Ruud

    RACER Developer

    I think I found it; during a shift the clutch is depressed and released. At the end, if autoclutch is enabled, the clutch is fully released. Without autoclutch, it stays as is, and during neutral phase it forces the clutch to go in. I've now modified it so without autoclutch, the gearbox shifting phases never modify the clutch. Seems to work with the mouse, I'll have to check with my G27 at home...
  15. Ruud

    RACER Developer

    Try downloading the exe at http://www.racer.nl/download/racer0831a.zip (I haven't checked in general yet, so it's just to try if this fixes your autoclutch problem; it might have an effect on autoclutched situations, not sure yet)

    It also does this:
    - Added racer.ini dev.note_ini_unused to check for unread car.ini parameters. See also http://www.racer.nl/tutorial/development.htm
    - The wind could get stuck in growing infinitely, making particles shoot away after a while
    - Differential reworked, since it had a bug (it accepted ratios <1.0).
    - Clutch wasn't restored after shifting when autoclutch was 0 in racer.ini and the car.
  16. The clutch fix seems to work for me :)

    Also, note_ini_unused is welcome, thanks for that as well.

  17. Tried it briefly with mouse as I have not much time to play, but works for me too :)
    Will try with steering wheel later.Thanks, Ruud!