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In this tutorial we end in having this end-product; see screenshot.jpg 

 

Screenshot.jpg 1 

 

Note: Make sure you have Photoshop and the Nvidia DDS plug-in installed. Also don't forget 
to download and extract the car templates, supplied by the Race 07 website. 

We will paint the skin for the Seat Leon 2007 model. 

Open '07 SEAT Leon Body.psd' in Photoshop 

We also want this nice carbon looking colors :-). In this skin I have used 3 different colors; 
carbon Black/Grey and Red. 

In the end you can use the Paint bucket with the Pattern fill option to fill selections with the 
newly created carbon look. This will be cool! 

 

To create this, follow these steps; 
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Step 1 - Create a new image 4x4 

Click File-New and select Width 4 pixels and Height 4 pixels. Click OK to create this. 

Zoom in to 3200% (CS3 | in older version the max zoom will be less) and you will have a 
window like in CarbonStep01.jpg 

(A keyboard shortcut for zooming in is CTRL+SPACE+LeftClick) 

 

CarbonStep01.jpg 1 
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Step 2 - Paint some carbon style pixels 

We will paint in 4 color gradients to make the carbon alike pattern. 

Paint it like in CarbonStep02.jpg. 

 

CarbonStep02.jpg  
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Step 3 - Define Pattern 

To fill selections with your pattern, you have to define the pattern. 

Select Edit->Define Pattern... 

You now see the pattern visually and you can give it a name. Choose Carbon Red for this 
example and click OK. 

 

* Create also a black and grey version of this Carbon Pattern yourself! * 

 

Close the untitled 4x4 pixel file(s) to make some room on your photoshop desktop. 

It is now time to actually paint your skin. 
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Step 4 - Fill the skin with your base color 

See Skin01.jpg 

 

Skin01.jpg 

1. Select the 'base color' layer (should be the bottom one) 
2. Now select the Paint Bucket tool (Keyboard G) 
3. Set the fill option to 'Pattern' 
4. Choose your Carbon Red pattern from the presets 
5. Click inside the template. It does not matter where you click inside the painting. 

Your painting should now look like Skin02.jpg 

 

Skin02.jpg 
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Step 5 - Paint the Carbon side skirts 

First get rid of the numberplates by clicking on the Eye icon of the Numberplates group 
layers. (open the layergroup 'Logos and such' and click on the eye in front of the layergroup 
'Numberplates') 

1. Create a new layer above the 'base color' layer. Name this layer 'Side Skirt Left' (Names 
are not a must, but it is easier to find the right layer back. Get used to always name your 
layers) 

2. Create a rectangular selection with the rectangular Marquee Tool (keyboard M) 

3. Make the selection like in Skin03.jpg 

 

Skin03.jpg 

4. Fill the selection with Carbon Black (Create this one similar to what I explained above, but 
now with black/dark grey colors). The Selection will now look like Skin04.jpg 

 

Skin04.jpg  

To create the same Carbon Black skirt on the right side can be done in 2 ways. You can 
simply create another rectangular on a new layer and fill it, or you can just copy the existing 
layer and move the part to the right place. I will explain the last way :-) 

5. Duplicate the current 'Side Skirt Left' layer by pressing CTRL+J. 

6. Rename this new layer (Layer 1) to 'Side Skirt Right' 
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7. Use the Move Tool (keyboard V) to move the layer to the other side of the car (the right 
side). To avoid left/right movement, use the cursor key UP. With Shift+UP you move 10 
pixels at once. Try to place this layer at exactly the right spot! (Use Zoom if needed) 

Your template will now look like Skin05.jpg 

 

Skin05.jpg  
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Step 6 - Paint the roof 

1. Create a new layer and name it 'Roof temp 1' 

2. Create a selection with the Polygonal Lasso Tool (Keyboard Shift+L to cycle through the 
lasso tools). Make the selection like in Skin06.jpg 

 

Skin06.jpg  

3. Fill this selection with the Carbon Black pattern 

4. Duplicate this layer with CTRL+J and name the new layer 'Roof temp 2' 

5. Flip this layer vertical. Click Edit -> Transform -> Flip Vertical 

6. Use the Move tool (V) to move this part upwards until the roof looks symmetrical. 

7. Select both Roof temp 1 + 2 layers with the CTRL key pressed. 

8. Merge the 2 layers with CTRL+E (Layer -> Merge Layers) 

You now have a template which looks like Skin07.jpg 

 

Skin07.jpg  

9. Create a new layer and name it 'Roof border 1' 
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10. Create a selection like in Skin08.jpg and fill this with a Carbon Lighter Grey pattern. 

 

Skin08.jpg  

11. Duplicate (CTRL+J) (and rename) this layer and flip it vertical. Now move (V) the border 
down until it is symmetrical. 

Merge the 3 layers (Roof border 1 + 2 and Roof temp 2) together and name the layer 'Roof 
Carbon' 

You now have a template which looks like Skin09.jpg 

 

Skin09.jpg  
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Step 7 Paint the side 

1. Zoom in to about 100%, enable the layer 'wire 07' (to help painting on the side) and 
disable the layer 'base color' for better visibility. Your template should now look like this. (To 
move around the screen you can hold the Space and drag with your mouse) 

See Skin10.jpg 

 

Skin10.jpg  

2. Create a new layer above the 'Roof Carbon' layer and name it 'Carbon side left' 

3. Make a polygonal selection with the Polygonal Lasso Tool (Shift L) and follow the wire 
frame as help. (Press Caps Lock to switch to a cross-hair which makes following the lines 
easier) Make the selection like in Skin11.jpg 

 

Skin11.jpg  

4. Fill this selection with Carbon Black 

5. Create a new layer above 'Carbon side left' and name it 'Carbon border left' 
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6. Make a selection like in Skin12.jpg 

 

Skin12.jpg  

7. Fill this selection with Carbon lightgrey 

8. Merge the layers 'Carbon Side Left' and 'Carbon border left' together (CTRL+E) 

9. Disable the layer 'wire 07' and activate layer 'base color' 

Your template should now look like in Skin13.jpg 

 

Skin13.jpg  

10. Duplicate layer 'Carbon border left' (CTRL+J) and name it 'Carbon border right' 

11. Flip the layer vertical (Edit->Transform->Flip Vertical) 
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12. Move (V) the layer to make the car look symmetrical. 

Your template should now look like in Skin14.jpg 

 

Skin14.jpg  

 

We are now done with painting. Its banner time! 
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Step 8 - Banners 

- Disable the layer 'Logos and such/Race' and enable the layer 'Logos and such/Race 07' 
(We are painting a Race 07 car :-) ) 

We will create 2 banners which we can download from the Race 07 website. Download the 
Race 07 FanKit here http://www.race-game.org/race07/download/fankit.htm 

After extracting the FanKit, open the file 'game logos\race07-logo.png' in photoshop. 

This banner is ready to go inside your template. 

1. Select the complete Race 07 banner you just opened in photoshop with CTRL+A 

2. Copy it to clipboard by pressing CTRL+C 

3. Select your Seat template file and make sure you select (click) on the group layer 
'Numberplates' 

4. Press CTRL+V to paste the clipboard. Photoshop will automatically create a new layer 
above the current selected (group)layer. Rename this new layer to 'Race 07 Hood' 

Your template should now look like in Skin15.jpg 

 

Skin15.jpg  

(You can close the Banner from the fankit now) 

We have to rotate and resize the Race 07 logo and place it nicely on the hood. 

1. Make sure the layer 'Race 07 Hood' is selected and select Edit->Transform->Rotate 90 
CW. 

2. Select the Move tool (V) and check the option 'Show Transform Controls'. You will now 
see a border around the layer content and some corner handles. 

We will now resize the logo to a smaller version but we need to hold the proportion of the 
logo's length/width. To do this, hold the Shift key. 

3. Hold the Shift key and drag one of the corners towards the center of the logo to make it 
smaller. 
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4. While you are in transform modus drag the logo towards the hood. Drag while the mouse 
is inside the rectangle (Cursor is shown black with white border) 

5. Resize and drag until you are happy. When you are ready press the 'Commit transform' 
button or press Return. 

The template should now look like in Skin16.jpg 

 

Skin16.jpg  

6. Rotate the layer (logo) until you are happy. To rotate, move your mouse near a handle of 
the layer content. (The handles you just used to resize!) The cursor will change into a bend 
arrow. Now drag the mouse and see how the layer rotates. 
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The template should now look like in Skin17.jpg 

 

Skin17.jpg  

 

Open the FanKit file 'Partner logos\wtcc.eps' in photoshop. 

Use the default settings while opening the *.eps file by pressing OK. 

1. Copy/Paste this Logo inside your Seat template just like you did with the Race 07 logo. 

2. Name the new layer 'WTCC left' 

3. The size of this logo is exactly what I like on this car, just Move (V) the layer into the right 
position. 

4. Duplicate this layer and name it 'WTCC right' 

5. Select Edit->Transform->Rotate 180 (We cannot flip because the text will be mirrored!) 

6. Move (V) the layer into the right position on the right side of the car. 
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Your template should now look like in Skin18.jpg 

 

Skin18.jpg  

Add some shadow to the WTCC logo this way: 

1. Select the layer 'WTCC Left' and click on the 'Add a Layer style' button at the bottom of 
the layers panel. Select 'Drop Shadow...' from the list. 

2. In the Layer Style Window uncheck 'Use Global Light', because both sides will get a 
different shadow angle. 

3. Select an angle of 135 degree and press OK. This looks nice isn't it? :-) 

4. Do the same with the layer 'WTCC Right', but use an angle of -45 degrees! 

We are now done with the body. Your template should look like Skin19.jpg 

 

Skin19.jpg  

Save your hard work as a *.PSD file, because you may want to edit it afterwards. 
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Step 9 - Save in DDS format 

1. Select File->Save As 

2. Choose the Format D3D/DDS (*.DDS). See DDS01.jpg 

 

DDS01.jpg  

3. Browse to your CustomSkins folder. For Race 07 Demo it is: ..\Steam\SteamApps\<your 
Steamlogin>\race 07 demo\CustomSkins\ 

4. Save the file as Seat_body.dds 

5. A new dialog window will open for the DDS options. 
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6. Select DXT1 RGB (No Alpha) from the top option list. See the red rectangle in DDS02.jpg. 
(If you want to save a Window/Helmet file, Use DXT5 -> blue rectangle!) 

 

DDS02.jpg  

7. Select 'Generate MIP maps' and choose '6' from the option list (See red rectangles in 
DDS03.jpg) (If you want to save an interior Window, use the option 'No MIP maps'. (blue 
rectangle) 
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8. Click the button 'MIP Map Filtering...' (See red rectangle in DDS03.jpg) 

 

DDS03.jpg  

9. Choose the Blackman Filter Type from the option list. (According other tutorials (GTR2), 
this will get the best results!). See DDS04.jpg 

 

DDS04.jpg  

10. Click OK and finally click Save. This can take some time for the body. 
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Step 10 - Create an ini file to link the body part to the game 

We are done with photoshop, close it. 

 

Open the Windows explorer and browse to your CustomSkins folder; 

..\Steam\SteamApps\<your Steamlogin>\race 07 demo\CustomSkins\ 

You will see the file 'Seat_body.dds' exist! hurray! 

Time to create and edit the ini file. 

1. Make sure you see file name extensions inside the Windows Explorer. Turn this on with 
'Tools -> Folder Options... -> View -> Uncheck 'Hide extensions for known file types'. Click 
OK to confirm. 

2. Right click inside the CustomSkins folder and select 'New -> Text Document'. See 
INI01.jpg 

 

INI01.jpg  
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3. Name it 'Seat_Tutorial.ini'. Click Yes to the warning about changing file extension. 

4. Double click the file 'Seat_Tutorial.ini' to open it in Notepad. If Windows ask for a program 
to use with this file, choose 'Notepad'. 

You should now have a screen like in INI02.jpg 

 

INI02.jpg  

 

5. Type your Team name inside triple brackets. For example '[[[Cool Racing Team]]]' 

6. Type your Driver name inside double brackets. For example '[[Johnny]]' 

7. Assign which car you want to link in single brackets. In our case '[Seat Leon 2007]' 

8. Link the body part to our DDS file. In our case 'body=Seat_body.dds'. 

You should now have a screen like in INI03.jpg 

 

INI03.jpg  

Save and close your 'Seat_Tutorial.ini' file. 
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Time to test your skin :-) 

 

Start Race 07 (Demo) and try your newly created car! 

Have fun guys, hope this tutorial was useful to learn some new things. 

 

Ramon van Rijn 


